Revopoint MINI firmware upgrade failed, unable to capture driver

Revopoint MINI firmware upgrade failed, unable t
1662443773307
o capture driver

Did you tried the new version of Revo Scan that was just released 1 hour ago ?

I have downloaded the new V4.1.0.software. But the software can’t catch the camera. Can the firmware restore the factory settings?

From what I see your MINI is not even connected to Revo Scan , but 2 cameras are visible in the task manager right ? something go wrong with your firmware update , I hope @Revopoint3d-Selina can guide you with this issue .
Did you tried connecting your MINI via WiFi to check if the firmware is bad or the driver issue ?
and check on the back if the LED is green and not blue …

The light behind is blue

that’s not good new @greenjason this means the MINI can’t reboot anymore , you will need to wait for @Revopoint3d-Selina until tomorrow with this as that is all I can help you here with for today .

Press the camera button five times continuously. It changes from red to green. But the installation still fails. The firewall has been opened

Originally it was green light. But as long as the 4.1 firmware is installed it will show that the camera is disconnected…but it can be used on 4.0.4…but the system device administrator still shows that the device is not recognized

Ok then at least it is not death yet and looks like driver issue , try to uninstall the 2 camera devices from Task Manager , unplug quick the USB from computer and plug in again , hopefully it recognize it and install the drivers the proper way , the cameras are plug and play so your system should recognize them .

I am out of options here , sorry !

Re-removing the device and re-inserting the USB. It still shows that the installation is unsuccessful. Is it possible that my system is WIN7?
1662474507522

When I installed firmware 4.1. I can grab the camera before the update. It will disconnect after pressing the install button

Yes that is possible , Revo Scan do not support Win7

I will try it tomorrow with WIN10. Thank you

1 Like

it also disconnected with my MINI while updating , then reconnected again after it was done .

Yes that would be better idea so we are sure it is not just Win7 issue here .

I can successfully scan the 3D model with firmware 4.0.4 in WIN7. So it should be usable. There is only a problem with the new firmware. So tomorrow I will try to install firmware 4.1 in WIN10

1 Like

If you can’t install proper the latest firmware, @Revopoint3d-Selina will assist you tomorrow as she can ask the developer team about this issue you have , but I hope it works for you on Win10 .

Hi Greenjason, may I have your contacts? Please check PM, we will troubleshoot this problem soon.

@greenjason

1 Like