[Windows] Revo Scan - V4.1.0 Official Released!

Dear users,

The new version of Revo Scan for Windows V4.1.0 is updated. Now you can download the new version from our official website or the link below.

https://www.revopoint3d.com/wp-content/uploads/download/Revo_Scan_for_win_v4.1.0.20220905c.zip

[Updated]

  1. Support dual-axis turntable;
  2. Optimise the firmware upgrade;

Please read The Dual-axis Turntable Quickstart Guide below for reference.

Best Regards,
Team Revopoint

3 Likes

Edit : Yes it is a new version — :wink:

1 Like

Works nicely with the Mini, the firmware update did not create issues.
Just wanted to test with POP2, with POP2 the truntable is not active.
It would be great to have that, too in a future update!

2 Likes

I hope too , since I use POP2 more latelly, Selina said they still developing the feature for POP2 and POP, so not ready yet.

2 Likes

@Revopoint3d-Selina

when I am scanning taller figure I need to manually change the angle of MINI , so I need 2 rotations for complete the top and bottom scan in 0 degree , sadly this option is blocked

I would love if the Developers team unblock this option , other way we are limited to scanning only objects that fits the preview scanning window when using the Dual Axis turntable , very limited to just little objects . And totally not usable with POP2 in the future .

Capturing frames while the Dual Axis change direction and not moving resulting in a junk overlapped data at over 200 frames for 2 angle rotations … little waste of time plus extra work for fuse, meshing and texturing .
The turntable should change rotation without waiting time immediately after finishing one rotation

5 Likes

I still can´t update the firmware in the new version. It still stops at step 2 - 20% . I’m using VPN too… :frowning:

I can not pair the dual axis to revo scan , can you help me

I experienced some problems between 4.1-beta and 4.1-Official releases

  • in Beta after coping turntable setup is mantained; in official release i need to uncopy turntable every time.
  • In beta i can expoer .stl in official i can no longer export in .stl but only in .ply or .obj
  • in both version .ply or .obj exports are not usable by Meshmixer.
    someone else had same pbls?

Firmware update is stil not working. Stops every time at step 2/2 @ 50%…tried it over 25 times now!!

I have tried it with disabling the firewall, tried it with and without VPN (Surfshark), installed WARP VPN and used it instead of Surfshark (as suggested somewhere else on this forum) but nothing works. It’s getting extremely frustating!!!

Any more suggestion Revopoint Support?

The fastest TurnTable mode is still 600+ frames.

I use the same setup as with the beta but i cant get a clean scan anymore. Even their own bust i cant get a clean scan from.
-45 degree angel of the scanner.
-distance "perfect’
-light settings are the same

I still get multiple stacks of the scanned object inside my “real” object.

360 frames should be only while rotating at 0 degrees , then you have the rest of it while starting stopping and switching what generates over 200+ frames
But the main rotation is at 360 frames as it should . The rest of the frames will be deleted while processing ( fuse and mesh)

Try to lower the MINI down keeping the same angle , when it tilts , the scanner should be parallel to the object at 75-90 +/-degrees.

I throw in so far everything that I usually test with , and the results was great after meshing .

Note: the dual axis turntable tilt should face directly your MINI as I saw people tilt the object on the sides what is wrong .

The number 90 should be in front of your scanner , or 270 if your outlet is on the left side . Just were the warning stickers are

same here over the last week ;(
tried all the things what are written, vpn, overwrite old install, setup a new version, start the update with the button in the settings window, start the update from the dialog who is popup if i start Revo Scan.
I need new ideas. I think the problem is the connect to the updateserver. Will try now a few other vpn tools …

…a few updates on things I have tried sofar:

  • Created a new user in windows (allready did this a while ago…) and installed revopoint on that account…issue stays the same.
  • Used the USB-C cable that I got with the POP2 to see if the cable micht be the cause…but issue stays the same.
  • It doesn’t matter if I use yesterdays Beta-version or todays released version of RevoScan.
  • With the Mini in Upgrade-mode (Blue LED On) I tried to have the firmware “updated” in V4.0.4. to see what would happen. Revoscan then asks me if I want to cancel or proceed with the upgrade. When I press Proceed then (also) nothing happens (but maybe that is because it is allready loaded with the latest V4.0.4. firmware…i dont know).
  • FW-upgrade now stops at 20% instead of 50%…

Anyway…I have no clue what to try next.

At this point I have a Dual-Axis turnable which looks nice but is completely useless and a POP Mini which firmware is not upgradeable…might also be the case with future upgrades !?

:frowning:

A lot of us have the problem theat the upgrade stop by 20% (befor was 50%). Whats going on at 20% - maybe that help us to find a solution.

@Maker1 I just updated the firmware of my old MINI Beta version ( without RGB) and works fine with the turntable, no issues and quick . So 2 of devices upgraded without issues , one with the older version and one with the new .

Maybe it is important or maybe not , but I use 2 cables , one for power and one for data connected to my PC , is it possible that when you use just one USB cable you get issues with the firmware update ? just giving you an idea … you can try using the mobile cable and connect USB A to power bank or whatever you have available and the USB C to your computer , and try again .

Allready tried that too…but issue stays the same…