Mini stuck on red light

Mini worked fine a couple of months ago when I last used it.
Needed it for another project saw Revoscan5 was out and downloaded it.

Installed revoscan5. Plugged in Mini. Get dialog updating firmware. finishes step 1/2 then step 2/2. Says complete. Mini led is now red. thinking I need to relaunch Revoscan I shut it down and notice a windows securtiy warning that the app wants access to my camera. Click allow.
Mini is still red… revoscan doesn’t find scanner.
unplug relaunch revoscan. Nothing
google reverting firmware and the issue.

Follow these instructions:

doesn’t act like the instructions in that it never turns blue.

Unplug scanner
hold play button
plug in scanner.
when red light comes on click play button once
A few seconds later green light comes on for about 3 seconds then turns back to red.

So I never get to the the blue light like in the directions.
So I try all sorts of combinations.

finally get to the blue light with the following combination

unplug scanner
hold play button
plugin in scanner
when red light comes on hit the red button once
green light comes on
while green light is on click and hold the play button for around 4 seconds
blue light comes on
launch revoscan5
finally says it will update the scanner.
goes through step 1/2 and 2/2 asks to unplug scanner. and plug it back in.
now scanner light is red and revoscan5 says can’t find scanner.
Tried two different laptops and my desktop
tried different USB3 ports

tried pluging it into my phone. Phone finds scanner and the light is blue.
Click scan
I get a “camera exception Failed to get camera’s information, please restart the scanner”

I also have a range scanner and it works great with revoscan5. on my desktop or my phone.

Hi @chasman,
According to your description, it is inferred that it should be a scanner hardware issue, I have already given feedback with the customer service team, please contact, our customer service staff will assist you to solve the problem.
Thank you for your cooperation and patience.