Mini Firmware Update Issue?

Hello all.

I have a RP Mini that I was successfully scanning with on a PC based set about 4 weeks ago using the combined cable.

However, when I went to scan today, I wasn’t able to get Revo Scan to see the device. I could see the cameras under device manager, I heard the audible sound when connecting the USB, but the LED on the back only showed blue.

I found some past threads here and tried to update the firmware- unplugging, holding the button until red, releasing, and then holding the button to green. This launched the firmware update in Revo Scan, but while on step 2, it seemed to update fine until 50%, then I heard the USB disconnected sound, it went to 71%, then seemed to skip to being complete, and then said the Mini would take about 15 seconds to reset. However, after the reset, all I have is a red LED.

Since then, I’ve tried to re-up date the firmware, I tried the 10 presses (nothing happens), I tried a different PC that it had never been on, I tried the USB A and C cable, I’ve checked camera permissions, and I’ve checked firewall settings.

All I get is a solid red LED.

Any thoughts? I appreciate any help.

Thank you,

ZK

Sounds very much as if your power source was not able to provide the additional energy required by the scanner when it started writing the new firmware into the scanner’s program memory.

What did you use for power?

Your firmware was not successfully updated and can’t reboot , the only way to restore it to reset it to original state what is the 10 clicks on the play button on the back of the device .

I would recommend to connect the device now to a power bank or charger using the split mode cable USB A and try couple more time to press the play button on the back of the scanner .

If this still don’t works you will need to get help from the customer support on Monday I tag in @Revopoint3D-Gena to check out on this .

The most issues users get when updating firmware on one single USB cable , not efficient power and data flow provided by the computer while updating what results in corrupted firmware update .
As always the best solution to use a separate power source

To power, I tried using a USB 3.0 off of the motherboard as well as a powered USB 3.0 hub that should provide plenty of power (runs flight sim HOTAS tons of LEDs, buttons, sliders, etc with no issue).

Although I didn’t have any luck doing this yesterday, I will attempt again later to do the 10 presses to reset the firmware.

It makes sense that the incomplete firmware update is the issue, I just don’t know why it was interrupted in the first place and why I was having issues flashing back.

I’m hopeful we can come up with something.

Thank you guys.

As I said, I think the power supply you used was just barely adequate for (let’s call it) standby mode, but when the scanner increased its power draw to write the EEPROMS (or whatever it’s using for firmware storage), the drain was too much for the motherboard and you got the USB Disconnect notice.

That’s not what happened Jeff, the scanner restarting and disconnecting after the firmware updates take place to reboot and to load the new firmware , it did not disconnected because of lack of power supply.
It did that on all my devices I updated and that is a normal process .

The update data did not processed correctly and the device need to be reset to factory state before next attempt. It is stuck on reboot .

I wouldn’t think updating the firmware would require more power than scanning, but maybe that is indeed the case.

Either way, I’m running the split cable now with the USB A plugged directly into a 2/3amp plug and still getting the same results-

  • Red light all the time from initial boot
  • No response to the 10 button hits
  • I can launch the update, but same as before… goes to 71% and then jumps to complete, but it’s back to solid red light afterwards

Thanks guys.

Pop, how do I factory reset? Hopefully something other than the 10 hits…

Thank you.

It looks like it is missing some components and trying to update it but get interrupted by the server .
It may not be any fault on your side @KingZeus

The firmware update process is more complicated that normally you would expect .

The best shot you have now to just wait for @Revopoint3D-Gena or @Revopoint3D-Cassie to help you with the process .

Don’t mess up with it anymore and just wait for the support as here is nothing you can do on your side .
They are back in office in 3-4 hours so you should get reply soon .

Sadly that is the 10x the play button hit
option only you have at this moment .

But the support will help you out … they did once to my device as well and it’s a manual process they will provide to you .

I don’t think that’s what he said happened.

What he said was that the firmware update got to the 50% mark, then he heard the USB Disconnect. The reboot happens much later, doesn’t it?

The description was confusing but that what actually what happened. When it reach the % my was 61% it disconnected and reboot .

@KingZeus
I have for you a one more solution

Please try following the steps to reset your device

IMG_20221113_203600

Pop, after 5., the LED goes red for a few seconds, then shuts off and resets, and comes back on solid blue. Once Revo Scan is opened, it launches the firmware update after a few seconds.

In response the earlier question, it seemed to be resetting in the middle of the second step while firmware update was running.

I appreciate all your guys’ help. I’m hopeful RP support can help out.

Thank you again.

ZK

@KingZeus if you followed the exact steps I just posted , try again

Disconnect it before starting and do again using the charger as power source , it should be 5V/2Am , not the computer .

You need to try again until it turns green following exactly the steps to each second .

If you can’t , don’t update anything in Revo Scan or you going back to the same issue again or even worse .

If you can’t turn it back to Green

@Revopoint3D-Cassie or @Revopoint3D-Gena will check on it with you and tell you what to do next .

Hi KingZeus, thanks for the details.
Please download the get_log_v2.0 folder, plug the scanner into your laptop, DO NOT run Revo Scan, wait for 30s, double click to run the get_log.bat, and there will be a log generated in the same folder, please send it to customer@revopoint3d.com

get_log.bat download link:
https://drive.google.com/drive/folders/1QqoXeBZKpKIY_oS09QSvAkaDIot_fP9O?usp=sharing

1 Like

Just sent it over. Thank you.