Solutions to Upgrade Stuck in 20%

Dear users,

We’ve received a few users’ feedback about the firmware upgrade stuck at 20%. Please try the methods below:

  1. Unplug the dual-axis turntable, and then power it again. Wait for 30 seconds, and then press the play button 10 times. It shall be back to the former firmware version.

The video below shows how to do it after powering it for 30 seconds.

  1. Download the software below and see if it works OK.
    RevoScan_4.1.0.20220905c.R.Test(adb-2).exe - Google Drive

  2. Please help us to check out the problem via online meeting. Email customer@revopoint3d.com if you would like to have a meeting with us.

  3. For Bluetooth connection issues, please close the Bluetooth on your computer. And then restart the scanner and the turntable again, delete the “dual-axis turntable” on the Revo Scan screen, search again, and connect.

We will update a new version of Revo Scan to solve these problems. Thanks for your understanding and patience.

Best regards,
Team Revopoint

4 Likes

Thanks Revopoint for the new version of RevoScan!

Now the upgrade step 2/2 go to 60% than then the process stops and start from the beginning on. Have this running now for around an hour - now we are missing just 40% ;(

60%? That’s 10% more than my update progress… You lucky guy. :wink:

it reached 60% and was successfully upgraded , never go above 60% in step 2/2 I upgraded 2 devices today .


yes, i am very lucky :upside_down_face:
how is your setting?
I use Win11, no firewall and antivirus at the upgrade time, vpn warp

Never reached that message that the firmware has been succesfully updated. It repeatedly started over again after 50% progress.

1 Like

but i get this by 60%
image

there is a mistake in this post Selina , it should be

  1. Unplug the MINI scanner, and then power it again. Wait for 30 seconds, and then press the Play Button 10 times. It shall be back to the former firmware version.

realized that and have done this

1 Like

internet connection has nothing to do in your case as you already downloaded the firmware in step 1/2 , the problem is now with upgrading process 2/2 , however for me it jumped to 60% and it was done on both devices . So something is preventing finalizing the upgrade on your device . I hope they find new solution tomorrow with new Revo Scan version . 60% is better than 20% …

I said yesterday that the Revo Scan is not ready yet even for testing , but everyone wanted it , that are the consequences of pushing unfinished releases .
Sorry Arnold for your wasted time , give it a rest until tomorrow .

I am starting to see a pattern , it is possible that only win11 users have the upgrade problems and not win10 users ( like myself) ? I know win7 users can’t upgrade the firmware on their systems either but it worked on win10 without issues …

Thank you!
It is not a problem to get a tool that is not 100% perfect. That’s what Kickstarter is for (sometimes). Do you have a large community for testing and so on. And you get a really great price for it.

I will try another things on my computer, maybe I have luck and can find the problem.

2 Likes

I’ve been having the 20% problem on Win 10.

1 Like

I have done the above suggestions for fixes, but I am still remaining at 20% over 40 minutes later.

That would be nice, but I’m on Windows 10 (Home) and even using the updated RevoScan above my Firmware update doesn’t go past 50% on the Mini at the moment.

…[edit] ah, and now I get this. Which isn’t the same as the error I got before. Oh dear.
image

1 Like

Reporting back in: The install keeps resetting itself to re-download the files, then sits at 20% again.

I tried resetting the scanner for a third time now, and it now refuses to acknowledge being connected to the internet at all.

10/10 experience so far.

That is a messy situation guys , they should know already by now why some can upgrade it without issues and others don’t, it was like with the early version of Revo Scan that don’t allow me to upgrade my POP2 devices but others had no issues , now it works for me but not for some of you. It is 11 PM in China for Revopoint , we see what they bring for you tomorrow . Hopefully the issues get resolved sonner than later.

1 Like

Installed the 3rd version of the 4.1.0-software (RevoScan_4.1.0.20220905c.R.Test(adb-2).exe] but the problem remains. So, sadly no working S/W yet…but at least Revopoint is working on it! :male_detective: :male_detective: :+1:

Let’s see what tomorrow brings… :four_leaf_clover: :four_leaf_clover:

nada

Reporting in again to say that now all I get is this error. My internet connection is fine, and revo scan has firewall access.

Quick edit: Now I can’t even press the button ten times to reset the revo mini. When I press it 10 times, nothing at all happens.