Mini fails to get camera information

I have a couple of revopoint scanners, of which the mini is one. This has not been used for some time, and when it is plugged in, there is no blue light. When I connect to a usb port, the scanner is found and displays the serial number (A22736392A6F00A64), but when I go to the scanning window, there is no display from the scanner and I get the message:- Fails to get camera information.
If I replace the mini with my POP2 scanner (no change of settings), everything works as expected.
I have rerun the update of the firmware onto the mini:- same result with the same error message, and also tried the wifi connection:- again same result with the error message.
In all cases, the blue light does not turn on. Does anyone have any ideas where I can go from here? (The pop2 works fine when I replace the mini in all scenarios).



Hi @chas

This looks like a hardware problem.
You can write to our customer service team at and they will help you solve the problem.

Best wishes

Thanks Jane, you have confirmed my views regarding this problem. I have contacted the support as suggested.



I am having no joy with customer support. I have emailed them a number of times, but have had no follow up. Any ideas how to get a response from them snyone?



Hi @chas

I apologize for the inconvenience.

Since our customer service team is busy with the shipment of MIRACO Kickstarter campaign recently, they might have overlooked your question. In normal times, they will actively respond to user questions.

Could you please record a video explaining your situation and send it to

I will contact the relevant people to check what went wrong and get back to you.

Thank you very much for your understanding.

What Chas is getting is this

I actually have the same issue on one of my computer but not on another , this issue is related to USB power and the system .

As for @chas I recommend you use the split cable that came with your MINI , USB C go for data and USB for a charger , if you use PC you can connect both of the cables , if Mac you can only use the USB C data cable and use separate power bank or charger .

In most cases the split cable will fix your issue , since it will separate your USB from data and power .
Please try this … it should works

I have tried to contact you over December and January to get to the bottom of the problem i am having with the mini:- but I am getting no reply or follow up from yourselves. I am now rather disappointed with the support you are supposed to be giving to your loyal customers.
I would be grateful for some follow up please @Revopoint-Jane


Hi @chas

I’m very sorry. The customer service mailbox is full of emails and your email may have been flooded. I’m contacting customer service now to take care of it for you.