POP Firmware update, failure?

I just updated the firmware on my POP scanner and it hasn’t come back yet. I’ve tried connecting it to USB and the network a few times and in each case the LED goes from blue to green. In fact when on USB I can use a camera app to see the camera from the POP, so it appears to work at some level. But beyond that RevoScan never sees it either on the Mac or the iPhone. FWIW I don’t see a connection attempt logged on my WiFi router either, and the original POP network doesn’t seem to work either.

The light on the back of the scanner should be GREEN , if it is anything else than green then you need to reinstall the firmware again .

See the steps if the back light is not green: [Tutorial] MINI | POP2 | RANGE - Firmware Update Error - Tip | Fix - #4 by PopUpTheVolume

It turns green and stays green.

Not sure how I would update the firmware again since the app never recognizes the scanner.

By following the link and the instructions , if it works then you can reset the last installation , if not I will have to move your issue to the Customer Services .

That was for the POP 2, I have the original POP without the play button.

Ok that is something that I can’t help you with here in the forum .
I will move your thread to the Customer Services and @Revopoint-Agnes will check out on this issue when she is back in the office .

If you don’t want to wait you can write an email to customer@revopoint3d.com including a link to this tread and explain your issue making sure you mention clearly it is POP1 firmware failure.

I suspect that the issue is related to this one. I don’t think RevoScan has access to the Camera devices on Ventura. I tried to connect to my MINI and it wouldn’t connect either. So for now I’m going to watch this thread and see where it goes.

I can’t help you here because without a button there is no way to reinstall the firmware or reset it .
And since everything was working just fine prior to firmware update it may be the issue .
Only the dev.Team can access your POP
For that reason I would wait for Agnes response on this subject first.

@dspeers Here please find the way for a POP firmware update:

  1. Download and install the latest version of the Revo Scan through this link: 3D scanner software Download Center - Revopoint 3D Technologies Inc.
  2. Connect the POP scanner to the computer via USB mode, open Revo Scan, click “Setting” in the lower left corner to modify the POP SSID and password to be the SAME as your home Wi-Fi, and make sure the scanner and the computer are connected in the same local area network;
  3. Unplug the scanner from the computer and Power on the scanner by an adapter/power outlet instead;
  4. Open Revo Scan, after the connection is successful, confirm it shows Wi-Fi mode, click “Setting” in the lower left corner and click “Update” to upgrade the firmware;
  5. Follow the steps to complete the upgrade, and ensure that the device is not powered off (focus on the color status of the indicator light) during the upgrade;
  6. After the upgrade is successful, plug the scanner into the computer via a USB cable and open the Revo Scan again, click “Setting” in the lower left corner and confirm the firmware version is updated.

Hope this helps.


The problem is at step 2. RevoScan isn’t recognizing the POP scanner after firmware update. I also have a mini and revoscan won’t see that either via USB. Both scanners do show up in the system report on the Mac (Ventura) and they both work with a third-party camera app.

@dspeers Hi dspeers, what do you mean they both work with a third-party camera app?
Did you try another USB cable or try with another computer?

So the POP scanners show up as USB camera device on a Mac. If you use a program like ManyCam you can access the camera on the POP1 and MINI. In part because in Ventura ManyCam already has permission to look at any camera attached to the Mac. I could be wrong but this leads me to suspect that RevoScan hasn’t asked for permission of the TCC system in Ventura.

Here is the POP1 showing up in system information:

And here is what ManyCam shows when connecting to that camera:

Meanwhile RevoScan keeps saying this:
Screenshot 2023-01-04 at 8.23.47 PM

The MINI behaves the same way, the only real differences that that blue tracking light comes on when accessing the camera via ManyCam. RevoScan can only see the MINI when its on WiFi. Neither the POP1 or MINI are recognized by RevoScan via USB.

FWIW I’m using the latest firmware on both the POP1 and MINI and the most recent version of RevoScan on the Mac using Ventura 13.0.1.

Please connect the scanner via USB cable, follow the steps below and fix the problem:

Step 1: Please read Problem 5 in this article and follow the steps to troubleshoot.

Step 2: If it is shown as Class for rockusb devices instead, please right-click the mouse to update the driver following the steps:

Click Browse my computer for devices

Click Let me pick from a list of available drivers on my computer

Click USB Composite Device

Click Next and update the driver

Hope these help.

I’m not sure why you think this would helped - if you look at the screenshot I posted it does show the right camera type already.

Hi Dan , just because the cameras are recognized by the system don’t means everything is working fine . I have the same issue on my PC where the cameras was recognized by the system still not by Revo Scan , I found out that using just one cable for both power and data does not work on my system no matter what I did , I switched to the mobile split cable and used the USB C for the data and the USB A for a separate power source and everything working fine since then with all my scan devices .
I got myself extension cables since the mobile cable is so short .

Try it out just to see if it working , plug the USB C to your computer and USB to power bank or any other power source with 5V 2Am.

I recommended this to other users with the same issues and it worked just fine.
You will also improve the frame rate doing it for better tracking and scanning .

I believe one USB cable was never the best solution with the devices and cause too many headaches already and the new firmware update may be just not helping here much , not with the connection or the quality of the scanning results .

Before the last update both scanners were working via USB using the same ports/computer. The only thing new (maybe) is the Firmware updated I did on the POP1 and an upgrade to OSX Ventura.

That said, I will try using the mobile cable. I’ll need to acquire a USB-C to USB-A adapter though as its an older computer (2017).

You can try and see if it works , nothing to lose here . You would get better speed anyway if it works compared to a single cable .

I’m wondering if this is what has happened to my second hand purchased POP.
Mine only works when hotspot wifi’ed to another device.

POP only works with Hotspot , POP2 with WiFi and Hotspot

I appoligize for reviving this old discussion, but this post is helpful.

I have connected via wifi in Revoscan 5.41. It shows as connected. I only get 3-4 frames per second even when connected by USB.

When I read up about this, it indicated that my Kickstarter POP 1 needs a firmware update to correct the framerate issue in Revoscan 5. I had hoped this route of Wifi Connection would let me update the firmware as you described, but the Update button is not present at step 4.

Can you please help me with this? Thank you very much for your time.