Mini can't be found since firmware update

Hi There,

After updating the mini’s firmware the LED goes red, then green and it doesn’t connect to the revoscan software anymore, neither it shows up in the system overview as usb device…

What went wrong?
Im working on a M1 powerbook, latest OS, latest version of Revo Scann.
My pop scanner works fine, the mini did until the update.

Can I restore the old firmware somehow?


What the heck.
Like a good old windows machine it started working again after several times of unplugging and replugging…

Sees as if the Problem solved it self…

Great Produkt by the way!

The lack of presence in the System Overview is the most concerning aspect. Did you use the same USB port for both the Mini and the POP? Would you try swapping the cables? (I know it’s a long shot, but it may help with the debug).

When connecting via USB, are you using the Mobile Adapter with a separate power supply or one USB port for both power and data? Do you have a USB Port Monitor that displays voltage and current draw?

Are you trying to connect via WiFi? Did you take into account that the Mini’s default conditions will be restored (Host mode, default password, etc.)?

Hi Jeff,

Thanks for the super fast response!

After some unplugging and replugging, the scanner suddenly started working again.

I then tried two different cables, both worked on both scanners, on both usb c ports of the m1 powerbook.

The mini was recognized, the firmware is reported as the newest version, everything work very stable at the moment.

I really don’t understand what was going on, because for some hours after the update the scanner didn’t react and wasn’t recognized as usb device by the laptop.

The last time I connected the mini it suddenly was active and I did several test scans.

Is there any kind of crash log I can look into or send to you?

The problem didn’t show again so far, so I really can’t tell what the problem was.

The power output was stable all the time, so that’s not the problem.

I usually don’t use the wifi, but will try soon.

Really a great device you guys came up with, but I assume you know that:-)

If I run into the problem again, I’ll be back, but for the moment there’s nothing to do anymore.

Seems like a weird software issue, perhaps in combination with recent OS updates and stuff like this ( too many updates, interfering drivers, new security procedures by Apple…)


Hi Christian ,

Jeff is forum user as you do helping members out , not part of Revopoint.

It is recommended to disconnect MINI or POP2 after firmware update and restart the software , new firmware is like a new scanner to the Revo Scan after update .
So it need to be rebooted or software restarted .

Hi Sszirsch,

Besides Windows I also use a M1 Macbook pro and had a similar problem, sometimes it would find the Mini or Pop2 and then it would not find and connect anymore, completely random.
The solution was that Revopoint support remotely installed an older firmware version on the Mini and Pop2, making them work again with the M1 MacBook Pro.

Hearing from your problem makes me think that the problem maybe is or isn’t solved in the new firmware version. Please report back if it fails to connect again.