Suddenly Pop2 refuses to connect

Hello,

I have a POP2 scanner that has stopped connecting to any of my devices for no apparent reason.

It’s been a little bit since I’ve used it last, but my general workflow as using Revoscan 4 over USB-C on my MacBook Pro M1 (macOS 12). This was working fine last time I tried to use the device.

Yesterday I tried to pull it out to do a scan and it said my scanner wasn’t detected. I tried multiple USB-C ports (both directly into the laptop, as well as into the USB-C hub powering my MBP) but I couldn’t get it to connect at all. I am at a loss as I’ve tried everything I can think of including:

  • Upgrading to Revoscan 5 on macOS
  • Trying the USB-A plug instead (both directly into my USB hub and into a separate USB power with sufficient amps)
  • Trying WiFi by connecting my macOS to the scanner’s wifi
  • Trying WiFi by connecting my iPhone to the scanner’s wifi using the Revoscan iOS App

Nothing works to get the scanner to be detected.

I can confirm (just based on reading other posts) that my POP2 scanner’s light is green in all cases.

Help, please!

Hi @coogle ,

sorry for the late reply.

For more details, please record a video and send it to our customer service email: customer@revopoint3d.com, our customer service team will help you solve the problem.

A video of what, exactly?

Hi @coogle if there is no WiFi Network showing up , something is seriously wrong , you did all steps well , I guess what the customer@revopoint3d.com needs from you is a video showing that exactly situation to determine if the scanner hardware is not working correctly, to recall the scanner they need a video proof to be sure nothing else is going on . Just routine check-in

Just to be clear, there is a Wifi network that shows up that I can connect to. What isn’t happening is the scanning being detected once I connect to that Wifi network. Do you still need a video of that?

Meaning the Revo Scan 5.1.0 do not detect POP2 after connection to POP2’s WiFi Network right ?
or it connect to the software , but you see nothing on the SCAN tab but the cameras preview are working ? that why they want video to see what is happening in the software after you connect to the WiFi network .
You can make screen shot of the software to show it too .

  • I plug in the POP2 into any power source (USB-A, USB-C, whatever), the device powers on and the light in back turns Green.
  • I open my device (MBP, iPhone), and I see the POP2 WiFi network
  • I connect to this WiFi network successfully using the default password (Renopoint3d I think?)
  • I open Revo Scan (4.x, 5.x, iOS – doesn’t matter) – it says it cannot find a scanner

That’s where things end for me – it cannot detect the scanner at all. It’s like the scanner isn’t connected at all.

image

Ok @coogle , that is clear now what is going on , @Revopoint3D-Gena
will check on you later tonight when they are back in the office .

@coogle Please don’t worry, we will help you out, I have send an message to you about when do you have time for an online meeting, please kindly check.

@coogle It seems like the issue is related to the connection between your POP2 scanner and your device. Please try to reset the name and password of your POP2 scanner.
Firstly, plug in and connect POP2 with the PC by USB;
Secondly, once the POP2 is connected, Click “Setting”, choose HOST, and enable the password as demo, revise the name and password as you like;
Then save, and the scanner will reboot.

If the issue persists, please contact our customer service team for online meeting assistance.

The POP2 scanner does not show up under any circumstances – it does not show up via WiFi, and it does not show up when plugged directly into USB. So I cannot follow your instructions. This is on a Macbook Pro M1 2021 running macOS 13.4

Hi @coogle
Please write to customer@revopoint3d.com and make appointment with the customer service for an online meeting , please include the link to this thread and your forum handle .