Pop2 and Mini not connecting via USB to Macbook

I’m unable to connect the Pop2 and Mini reliably via USB to my Macbook.

I’ve tried to connect the Mini and also the Pop2 to my M1 Macbook pro, the Mini in rare occasions connects, but the Pop2 won’t connect direct. I had the Pop2 connect once or twice when I connected the Mini first via USB, then plugging in The Pop2. This was with the 4.1 Mac software version.

With the 4.2 Mac version, sometimes when I start up RevoScan it gives a message that it wants to connect to the scanner via USB but then nothing happens in the application. When pressing scan it says no scanner connected.

I tried connecting the scanners via one cable to the Macbook, so it uses the laptops battery and also via the split USB cable, where power is supplied via a USB powerbank. In both cases the scanners won’t connect.

Any idea what could cause this, and how to solve it?

I guess you tried all possible combinations, what about using the split cable with power bank and wifi ?

I am only Windows user myself and test Windows/Android apps so I am limited here with ideas , I am using split cable myself all the time to reach maximum frame rate while scanning .

I can tag @Revopoint3D-Gena to check on your issue here on Monday .

Connecting via Wifi works for both, but sometimes gets a bit choppy when the file gets bigger.
Also the scanner must be connected to open previous scanned files from from the list.
My thought was that a cabled connection would be better in this case.

Just make sure the device working and nothing else on the hand with it .
My single cable connection sometimes works , sometimes not so now I use just the split cable with extension , USB A to my USB hub and the other for data to USB C .

The split cable USB A male goes for power only , and USB C for Data only to your computer .
And it should works 100% .
Never connect both cables to you Mac . It works on Win but not on Mac .

Ok, thanks for the information so far.
Let’s see if Gena can come up with a solution of info.

I see too many issues today I am wondering if it has to do with the new Mac version .
Anyway @Revopoint3D-Gena will be back at work on Sunday evening EST so she can evaluate better the issue and ask the dev team directly . Right now the office is closed for the weekend so not much I can do .

Hi Martijn, please watch this video to refresh the USB Device Tree until you can find Revo_Product, if not, please unplug the cable and plug it again to make sure you will find Revo_Product.

If this solution doesn’t help, please let me know.

Thanks Gena for the video.
This is what I tried:

Mini connected to powerbank and Usb-c plugged into the M1 MacBook, System info => refreshing the USB field, it shows nothing.
Then I tried and let the USB plug connected and disconnected the plug in the Mini, it now has to start up again. After refreshing the USB field in the System info field, Revo_Product sometimes shows up but then disappears. In some rare occasion it does connect, but mostly it won’t.

I tried another M1 MacBook Pro, but this gives the same result.
Then I tried an Intel MacBook Pro, this one works as it should, plug in the USB C cable and it connects, every time… On the Intel Macbook it seems to always connects to the USB 3.0 bus, the M1 only has USB 3.1 available.

Hope you can help with this.

Here are screenshots, dark is the Intel Macbook and light is the M1 MacBook.


Untitled Medium

Thanks for isolating the problem, that helps a lot.
Please check if the macOS version for your M1 and Intel Macbook is 13.0.1 Ventura.

Yes, it is up to date with the latest version.

I’m having exactly the same issue with my MacBook Pro M1 Max and Ventura 13.1

Feels like something is broken in the way Revoscan is handling the new accessory connect feature in Ventura.

@Revopoint3d-Agnes this issue was not addressed since December 22 , can you please follow on this issue above today?

Hi nlavelle, please find the firmware version and software version in Revo Scan and send me a screenshot.
If you can’t find the firmware version due to connection issues, please oberseve if the indicator light back on the scanner is turning red and then green when power on.

Hey Guys,

On a hunch I uninstalled the RevoScan app and re-installed and as if by magic the Ventura Mac can now see the scanner and it all seems to work.

I think this is a case of re-install and it will work

Thanks @PopUpTheVolume for escalating :wink:

Thanks

Neil

2 Likes

Hi Neil,

How did you uninstall the app? I’ve re-installed/updated the app on the Mac and that didn’t help. So I’m guessing that something needs to be removed/reset to get this to work again.

Dan

Neil Lavelle neil.lavelle@googlemail.com Sun, Jan 15, 11:24 AM (22 hours ago)


to Dan

Hi Dan,

I disconnected the device, moved the RevoScan app to the bin, explicitly removed it from the bin, re-installed and re-connected the device.

It just worked - I appreciate that it doesn’t help you.

It looks like they install it all under /Applications/RevoScan.app so as long as that’s gone I’m not clear where else to look…

Do you have another older mac you can test the device with?

N