Device not found on Windows 10

Hi all, with a fresh install of HandyScan 2.4.8 on W10, it can’t find the Pop scanner: “Device not found, please plug in”. Same story with 2.4.7. No antivirus problem. The Pop seems to be seen not as a camera, but as a “non specified” product branded as ZXProduct.
Camera authorization was triggered as suggested on other posts.
I tried also with and without powered USB Hubs, and i also tried both cables.
While connected to computer, the led turns green , as expected.
The scanner works in Wifi mode on a Huawei Mate 9, so the scanner isn’t faulty.
I have absolutely no idea on how to solve this issue… Any help?

Hi, @tymeorama
Could you please make sure that the port on your PC is USB 3.0?


The usb plug color on the computer are blue or black?


It is USB 3.0 port (Blue). tested on 2 different ports, also with certified USB 3.0 powered Hub. I also tested on USB 2 port

I also swap the USB cable for another one: same results: no device found by Handyscan.

Can you please tell me if in Device Manager the Pop appears after you plug it in.

And if it detects it can you tell me what it displays?

Thank you in advance

yes, the Pop appears in Device Manager. It seems that there is a “?” on th eRockchip label? Maybe it is a driver problem… I included some screenshots. Thank you @Zoltan3D for your help!

Is there anything I can try to get the scanner to work on Windows 10?

Here are some more informations about my device

Elsewhere, I have read that you have to set the permissions for the POP (which is registered by Windows as a Camera) to be accessed by the HandyScan software. I don’t have Windows 10 (yet, it’s on its way), so I can’t tell you how to do that, but you might try searching with the terms “Windows camera”, or maybe just “camera”.

*** EDIT ***
I found it. Read this post:
*** EDIT ***


Thank you @JeffLindstrom , I’ve read the post you refers to before I posted about my issue. You can see on the many screenshots I posted previously that it seems that my scanner isn’t listed as a camera, but as an unknown device.
I tried to set the permissions, but I couldn’t find any camera related device linked to the scanner. I tried to check the drivers: no more luck. My windows 10 was a fresh install less than 1 year ago… I’ll keep searching

Hi @tymeorama
Sorry, we will discuss this internally and reply to you as soon as possible.
Is it possible for you to try the POP on another PC? (We think if the POP works on another PC) Thanks.
Best Regards

I have a similar story about win10. Handy scan installs but Handy studio doesn’t.
also the camera doesn’t install. Handy scan also says “device is connected” when I plug it in but eventually changes to “device is disconnected” soon after. light goes from blue to green.
device manager calls it an unknown device.
My computer is a latte panda alpha. it is running a tablet addition of win10.
Also it works perfectly on my new computer. So your hardware is fine.

I tried to install the software on another computer, with a fresh install of Windows10 Pro : averything works smoothly. The main difference between my 2 computers (same Handyscan version): the new one detect the scanner as a camera, the “old” one detect the scanner as an unidentified device (not as a camera). This is why Handiscan can’t connect to my scanner on my “old” computer: becaus eit is not labeled as a camera.
This is what appears on my “old” computer: ZXproduct (the scanner) appears as an “non specified” peripheral.

The only thing that comes to mind, for me, is that your OS builds are not the same and that you do not have the same DLLs. Some DLLs will have to be different because they work in the abstraction layer to different hardware, but others (like device recognition) should be the same.

Do you have automatic updates enabled on the computer that isn’t integrating the POP? If not, try forcing an update. A more involved approach would be to wipe your computer’s boot drive and re-install from scratch, getting the most recent drivers from the internet without overlaying older drivers (which might fail).


@JeffLindstrom the computer that isn’t integrating the POP have automatic updates enabled, but I’ll double check the OS Builds.
I won’t be able to wipe this computer as it is my primary computer for my job, and I don’t wan’t to mess anything with my current projects…
If I get the DLL list, I can check if some of them are different between my 2 computers, but I’m a little bit skeptical about that because I can plug other cameras into my computer (including Imaging Edge from Sony) and everything works as intended.

I checked the os version:
On laptop A (where POP doesn’t work, see previous posts):
Édition Windows 10 Professionnel
Version 21H1
Installé le ‎13/‎02/‎2021
Build du système d’exploitation 19043.1023
Expérience Windows Feature Experience Pack 120.2212.2020.0

On Laptop B (where POP works):
Édition Windows 10 Professionnel
Version 21H1
Installé le ‎05/‎06/‎2021
Version du système d’exploitation 19043.928
Expérience Windows Feature Experience Pack 120.2212.551.0

So basically, the computer A is more up to date than Computer B, but POP doesn’t work on A, But on B everything works.

I removed and did a clean reinstall of handyscan: same problem

I suspected that the drivers may not be the good ones, and I compared the drivers on the working laptop vs the NOK one. I found that on the computer where Handyscan wasn’t able to find the POP, the driver was not a good one (Rockchip driver), and the POP didn’t appears as a webcam, but as an unidentified device.

So I remove the “bad driver”, and I added 2 missing drivers I got from my working laptop. After several reboots, I just had to set up the antivirus to authorize Handyscan to get an access to the POP, and it worked!

I tried to make a How-To : maybe it can help others @JeffLindstrom @Codejockey @Zoltan3D @Revopoint-Cassie


Congratulations. I figured it would be the drivers, but how did you figure out that the Rockwell driver is incorrect? Do you know which program installed it?


Hi @tymeorama
Thank you so much for this update. This a good news! Congrats!