Problem connecting device on Windows 8.1 pro

Hello, I’m having a problem getting the POP device to connect when running on Windows 8.1 pro.

When I plug in the device, the light turns green and I hear the chime sound indicating that the device has been found. When I look at the devices list it shows up as ZXProduct so everything seems good.

However, when I launch the HandyScan Software, I hear a chime sound once again and the ZXProduct device immediately disconnects and is no longer seen in the device list. The HandyScan software then reports that the device can’t be found and asks to plug it in.

For some reason the device seems to disconnect the moment that the HandyScan software in launched.

This is a dual boot machine with both Windows 8.1 pro and Windows 10 pro installed on it.

I should point out that when running on Windows 10 professional the device can be found and remains connected when the same version of the HandyScan software is run. So when running on Windows 10 everything functions as expected.

However, as I mentioned the hardware automatically disconnects the device when attempting to run on Windows 8.1 pro.

Any ideas ?

Please advise.

Kind Regards,

Joe Saltzman

The scanner looks like a camera to the PC, and while I don’t know much about Windows 8 (which I skipped entirely), Windows 10 has caused problems for some users because camera access is restricted by default.

1 Like

Yes indeed. I’ve continued to investigate the issue I’m having on Windows 8.1 pro and it seems that the scanner will connect and be recognized by the OS initially, however after about a minute or two it will automatically disconnect. As I said earlier, it will also disconnect if I attempt to launch HandyScan. It’s pretty weird… LOL. Still, it is working fine for me when running on Windows 10 Pro.


Hello everyone, I think that I’ve managed to solve the issue, here is how I did it.

Go into Windows Device Manager, locate the “Universal serial bus controllers” listing and expand…

Go through each listed entry, right click and choose “Properties” find the power management tab and un-tick the checkbox that says: “Allow the computer to turn off this device to save power”

I did this for all the listed controllers.

Doing this seems to have solved my issues. Now the camera connects, the connection remains active and does not drop. Also now when I launch HandyScan the Revopoint POP scanner remains connected.

So it looks like this has solved my issue… maybe this information can help some of you !

Fingers crossed & good luck !



1 Like