Weird Spiral Scan

Hi All,
I was attempting to scan a large steel Pump Housing in an outdoor setting a few days ago.
I waited until after sunset to avoid any IR issues and tried the scanning with both my laptop and my Android tablet.
I would start the scan, then without even moving the scanner, the scan data would show this “Spiral” snail trail appearing on the screen.
It did this despite not showing a “Lost Tracking” or “not enough points” warning.
You can see that the object has plenty of geometry and also some texture.
I tried the scanner again when I got home and it worked fine.
Any Ideas ?

There are too many big flat surfaces.

You need to use marker

1 Like

lol i thought i m only one have this issue, or range can be used for scanning 4th dimensions…

had this often when using the Mini. its like the software doesnt use the gyro sensor in the scanner and just starts making stuff up.


This is due to not having enough features , each feature need to be at least 8cm apart from another feature .
You need to use Body Mode and in case of this object probably a standard mode /not High Accuracy mode .

Also when you are in Body mode set the range from 300 to 1200 mm
How far you go how less features you need to be in FOV .

If I was doing it , I would use my white cube magnets and stick it 8cm apart on the most flat surface and scan it in sections and merge later .

The gyro only help capturing the first frame position in space , the rest of the frames follows the position and need tracking features to align proper like a puzzle, if there is no feature in area of 8x8 cm to hold too the frames sliding out, creating the snake effect .

Nothing wrong with the scanner or software , it is the object …

1 Like

Lack of features nothing more nothing less Adam , that how structured light scanners works , they need features since you projecting a lines on the surface, if there are not distortions of the lines there are no tracking points , and the software see it as an empty space .

Lol that is not an issue , no matters $700 or $100K scanner, no features or markers, no scanning …

this is the way …


i like the Mandalorian reference you slipped in there. May the fourth be with you.


nice one Adam forgot May 4th today , big fan of Mandalorian and Star Wars

… May the fourth be with you !

Thank you Catharina,
I had already 3D printed some Cube Magnets, but I didnt think I would need them.
I will give it another try.


Great job on that cubes Mike , I made my own as well .

For the object you trying to scan white cubes would works best without need of marker mode as it is rather slow at this moment in RS5 , at least 8 cm apart , scan section , move cubes to new area , scan another section , etc etc

At least 3 cubes visible at any time in your FOV .

I hope it will works out great , it is not a simple object to scan , lots of data will be collected in the process but the result could be super great if you manage to scan it … can’t wait to see …

A new batch of white cubes hot off the 3D printer :slight_smile:

1 Like

Hi, when you say the Marker Mode is rather slow at the moment, is it one of the things that is being improved ?

Hi Mike , download the latest version of RS 5.0.6 it was improved already .

However Marker mode is always slightly slower from regular feature mode since the software build the tracking map using only the markers it captures and actually ignores the rest of the object features .
The normal speed is between 7 to 9 + with Range , how faster the Frame rate how better of course , especially if you scanning handheld .
I checked yesterday the speed was around 9.4 fps what is good .

wow, so stick the cube on the top of the scanning object? and remove in RS5 after scan? will this step affected the final product shape?

It depends, you can place cubes around the object as well , but in case of Range features need to be max 8cm apart to be tracked properly.

If you put the cubes on top of the object , it can be removed from the point cloud , there is many interesting way how you can use it , for reverse engineering it even don’t bother as you just ingiring it while reconstructing the mesh .

1 Like

An Absolute Arm would be able to handle it. Too bad it’s the cost factor.

Limits of the Revopoint Range, which stinks

It feels like Photogrammetry would be better for these larger objects with less features.

i’ll need to try this since markers are not allowed on objects I work with.

That has nothing to do with Range , it is a structured light technology that requires the object to have features to be able to scan it , no matter you spent $700 or $27.000 for a scanner , the object itself still needs features for tracking . That’s are the rules of scanning and not limitations .

Simple objects without features are easy to recreate manually in modeling programs so nobody bother scanning it generally, scanners are helpful for objects that are difficult to replicate because if it’s unique features .

Features is too vaguely defined.

A simple bee-hive shaped basket had a simple shape and feature. Meanwhile, large irregular shapes seems to be problem. So does that make it a limitation? Sounds like it.

The tracking either is working crudely or causes these spirals of deaths. Difficult to replicate would be a large object with difficult to replicate in terms of manufacturing and yet it has problems.