[SOLVED!] Revopoint Mini 2 - Scanner Disconnected - Class for rockusb devices/Rockusb Device

My PC can’t recognise scanner. In device manager there is “Class for rockusb devices/Rockusb Device”. What to do?

Hi @Fokus

This could be caused by your computer not recognizing the scanner correctly.

Please connect the scanner via the long USB cable, follow the steps below and fix the problem:

If it is shown as Class for rockusb devices instead, please right-click the mouse to update the driver following the steps:

  1. Click Browse my computer for devices

  2. Click Let me pick from a list of available drivers on my computer

  3. Click USB Composite Device

  4. Click Next and update the driver

Please try this to see if it works and contact us again if you still have problems.


Thank you! Solved! Windows 11:

Right click [Start] button → [Computer Managment]
Select [Device Manager] on left panel
Right click [Rockusb Device] under [Class for rockusb devices] → [Update driver]
Choose [Browse my computer for drivers], then [Let me pick from a list of available drivers on my computer], then click [USB Composite Device].

1 Like

Glad to help you and thank you for sharing this soiution. :+1:

1 Like

Thankyou for posting this solution. My pop2 wasnt being found besides through wifi and dropped the fps down to 6ish, was a pain to scan as tracking issues. Now followed this and back to cable connection and can scan at nearly 15fps again. Cheers for the write up.

1 Like