Rev mini not detected in scan

I just received my mini scanner. I installed the software on win 10, Revoscan does not detect it. I tried changing camera permissions, folder permissions… everything. I noticed in DEVICE MANAGER it is listed as,

“Class for rockusb devices” in the sub menus of that, it lists,

“Rockusb Device” with a small question mark (?} with a circle around

I am stumped.I also couldn’t find my serial number for Revo Studio as well.

thank you!

If you are certain that “Rockusb Device” refers to the Mini’s device driver, I would suggest disconnecting the Mini and uninstalling the driver (in Device Manager). Then, uninstall Revo Scan.

Then, shut your computer down, restart it and, making sure your computer is connected to the internet, install Revo Scan, open it and finally connect the Mini.

Make sure the Status LED on the back of the Mini settles on green and doesn’t flicker.

I am slightly concerned your USB port is marginal and the Mini isn’t getting stable power to operate. Do you have the dual cable so that you can set up a separate power supply (specifically, one of Revopoint’s battery packs)?

Hi, thank you for your reply. Yes I have tried both ways it works fine on my phone with a battery pack. My laptop is a very high-end laptop and can charge my phone which is a 21 ultra. I was possibly planning to see if I connect the USB to my computer then use the other cable to the external battery pack and see what happens I’m very puzzled I cannot figure this out whatsoever thank you again.

Do that and see what happens. If it does not solve your connection problem, then use the split cable and battery pack during the uninstall and reinstall procedure as I described above.