Device not found - Green light

Just tried to set up my Revpoint POP 2 3D Scanner on a Windows 11 PC (bought via Kickstarter). No matter what USB I use: USB C, USB 3, USB 2, nothing connects! Device not found. Very frustrating. Light on back is green.

I have multiple different USB ports and have tried them all. Privacy settings are allowed. I have installed the Scan and the Studio software.

Are there any other troubleshooting guides I can use? Apart from the obvious which I have done already (rebooting, reinstalling, unplugging, etc.)

Or should I send it back for a refund?


There’s a few different situations that could be causing your problem.

Take a look at this first site for some things to investigate: .

If that doesn’t solve your problem, here’s a more generic approach that also works for Windows 10:

Hi John , after you checked @JeffLindstrom recommendations , you can do as follow

After you connected the device via USB C for example , first you need to check if under Device Manager >Cameras you see 2 camera

if you do, you will have 2 additional options since it looks like your motherboard’s USBs do not provide enough power and data flow with just one cable.

If your PC support dual band 5Ghz wifi you can connect the one cable USB A to your computer for power, and connected the data via WiFi .
If your PC do not support 5Ghz WifFi
you will need to use the mobile cable that you find in the box with 2 cables , one is USB C and one is USB A, connect the USB A to power source like charger or power bank 5V/1mA and the USB C is for data to your PC .

however …
For a quick test you can just connect them straight to your PC both at the same time the USBA first then and USB C , open Revo Scan and see if the device is recognized , I know the cables are short , but that is just for a test to see if that is device issue or USB port that can’t support both power and data at the same time via just one cable .

if the test is positive and the software did recognized the device this means you will need to get yourself some extension cables and use the mobile connector .

I have the same issue and POP2 never worked on my workstation via one USB cable and I have a very good PC . I have to power it via second cable to make it works .

So you have 2 more chances , if it does not work , you will need to contact customer services for future assistance .