Revoscan 5.4.1 doesn't see the Miraco over USB (MacOS)


I just updated Revoscan to 5.4.1 on my Macbook Air M2, and although there is an option to Import from Miraco over USB, it doesn’t see the scanner. The scanner is connected using Data transfer mode using the supplied USB-C to USB-C cable. No popup or anything appears in Revoscan, and if I click File → Import from Miraco → USB, I only get a popup that tells me to connect the Miraco in Data Transfer mode. What am I doing wrong?


Same problem here. The connection socket seems to be a little bit shaky. I tried it several times, only one time it seemed to work for a short time, Miraco was recognised by Windows and Revo Scan, but then again not.
In Facebook they said, this could be a problem with DELL laptops (as I have indeed).
Immediate support would be great!

Also tried the other mode on MacOS. It does connect after a while but doesn’t work. For example, I started calibration since I am experiencing more ghosting than I would expect, but the scanner doesn’t seem to be given any data to the app. In the practice mode nothing happens and all movement markers stay gray.
After that I tested both modes on windows and there they work fine. Could import projects over USB and was able to recalibrate the scanner.

Hi Daniel , I have win11 PC workstation and Dell win11 tablet PC . On my Dell tablet everything is working just fine and on my PC only Data Transfer and Import via WiFi …

So this is nothing here a support can help you with , as it depends of the maker of your computer and it’s hardware .

There is not really fix to it if your computer don’t works in PC mode when connecting MIRACO via USB cable . USB need to be minimal USB 3.0 and the motherboard need to support the proper voltage, in most cases it don’t .

However the Data Transfer via USB should works , as that is a simple protocol.
You have also single USB cable from POP3 , try that in place of the white cable .

I requested and suggested the charging function of MIRACO to be disabled while connecting to computer , so hopefully it will help out some how but not sure yet if my idea will works in this situation .

Hi @Bjrno , sorry but can’t help you out with Mac issues, Win only here …

Please write to if you experienced connection issues between MAC and Miraco .

The data import via usb only worked one time, the next time i plugged in USB cable, Miraco wasn’t recognised. Tried both black an white cable. Short success only with the double USB-C. At least Revoscan let my import Miraco files. Unfortunatley I didn’t check if pc mode worked.
Also Wifi doesn’t work. Miraco is in the Wifi, but the transfer gets an error: please check if Miraco is in the same network. I have a master/slave repeater network, but of course same SSID.
If Miraco is only working with special hardware brands, that should be stated.
Until now, not so happy…

So if it let you import Miraco files via Revo Scan so what is the problem ?
You can’t do that without Transfer Data connection .

Go to Miraco Settings , then plug in the white cable to Miraco and your computer and see if under settings you get USB label on top , if yes click it and choice your connection type …

As @Bjrno mentioned early today there is issue with channel 112 in Europe , this maybe your issue of the setting of your router .

I never said that , this have nothing to do with specific brand but the quality of the motherboards that not always deliver as promised , so it is not Recopoint fault that on one computer it works and on another it don’t .

Please follow the steps that I mentioned above , you should have no issue with data transfer using USB , just activate it via settings after connection , if you do not activate it , there is no connection .
Data transfer works on all my computers regardless.

Thanks for fast reply!
I tried plugging in the white usb cable for several times. Mostly nothing happened. Mostly even the USB options screen on the Miraco didn’t show, there was only a sound. Only ONE time Windows recognised a new USB device an opened the file system. Starting revopoint the same time, i got a screen which asked me if i wanted to import miraco files. Didn’t try the pc mode at that time, so I actually don’t know if this would work,
Is the cable broken? But charging works…
Jermaul in Facebook said we should try another cable, but I have no other double-C.
But it should work also with a Type A to C USB cable capable of data transfer from a smartphone, shouldn’t it?

If you hear a sound on your computer you need to set the USB mode from Miraco settings … that is the best way .

It works even with all POP3 cables you have … As long it is a data cable , so your phone cable is all fine .
I even used cable with C to A adapter and the transfer data works just fine …

PUTV, i think it all dissolved in pleasure: yesterday my laptop was short on battery (power cable wasn’t plugged tightly). Maybe this was the reason the usb connector was shut down…
Sorry for being impatient!

I forgot to mention that , my tablet did the same without the charging cable …so yes that may fix this issue as Miraco is charging while connected so not enough power will shut down the USB connection on your computer and MIRACO is very power hungry .

Thanks actually for a reminder !

Using my Mac, I was unable to get Miraco to connect when using a fully wired USB3 cable. When I switched to the cable that came with Miraco that is USB2, it works fine.
There is a warning when connecting the Miraco to a M-series equipped Mac to this effect.

My guess is that it’s a power issue.

According to Dev team the USB need to be USB 3 or USB3.2 to work correctly in PC mode . USB 2 not so , so why they would include a USB 2 cable ?

I am guessed this for the last 2 months , but my tablet working fine with PC mode and Miraco on any data cable .

Not on my PC with USB 3.2 or my powered USB C hub or PCI 16 USB C so power is not exactly the issue .

The issue is that Miraco is charging while in PC mode , data and charging at the same time draining my tablet battery in 20 min …
Once they shut down the charging it will works on any devices regardless USB 2 or USB 3 .

They working on that already … so hopefully fix come soon …

Miraco was not designed to work in PC mode or be used as a PC scanner to begin with but as stand alone device, this option was added at the end of the trial because of requests … so this feature needs a little more time .

We just need to wait it off …

Data transfer should works on any port since it it regular protocol and not UVC based .

Only WIFI transfer is available for detection here. The Miraco is visible in “Task Manager,” but File Explorer or Revo Scan 5.4.1 cannot detect it.

It’s frustrating to spend hours transferring 30GB over WIFI.

I have a quick question about WIFI transfers – if anyone has a solution: when I share one model, it seems that all my models are shared instead of just the scan. Do I need to relocate the models to an empty project? In other words, does it transfer everything within a project?

You can’t transfer just a single scan, you need to transfer the project , there are no option to share a scan only . Project is a part of all the scan data , it can’t be split .

You need to activate the Data Transfer mode under USB settings on Miraco , please use only the white data cable or any other proper data cable …

After you change the USB on Miraco to Data Transfer , open Revo Scan and create new project , and in the menu bar you will see option to Import from Miraco , choice USB and library will open .

It’s good practise to make a new project for each new object you intend to scan. It makes scan data management so much easier. I learned this quickly after I got my Miraco.

I have exactly the same issue on a Mac. It doesn’t work over USB or WiFi. Works on a borrowed windows machine

Hi @Monstersinthewild

The dev team is working on a solution to find why some computers do not respond, the thing is , that for some it works , for other it don’t and there is not yet found a reason why it is like that .

Nothing to do with a brand , or operating system … but possible to do with the USB port that can’t handle the power and data flow .

You see on my win11 tablet everything working fine … but on my win11 PC only Data Transfer mode is working .

Many people use the turntable cable USB A to USB C trying to connect ( this is not a data cable , only charging cable )

You need to use the original white cable that came with MIRACO USB C to USB C connected to a USB 3 port .

That’s all I can help you here with at this moment , once solution is found that works for all the team will post it .

1 Like