Miraco file transfer to MacBook Pro issue

My first attempt to transfer one file from Miraco to my MacBook Pro M2 using the white USB cable that came with the Miraco worked nicely.
Today I tried to transfer another file doing the same steps, but no window pops up in Revoscan.

In Revoscan, I opened File>Import from Miraco>USB and a window opens that says I need to connect with the USB… it already is. I even tried the other 2 USB ports. No luck.

The window on the Miraco (where it lists the 2 Methods for transfer) says at the top “Currently in data transfer mode, please do not disconnect”. Nothing has happened for ~10 min.

Help, please? and thank you,

Hi Pamela ,

Sometimes it is good to reboot Miraco if something like that happens.
If you still experience the issue after rebooting Miraco please contact customer@revopoint3d.com for technical support .

Thanks, I will try a reboot. Meanwhile, I tried WiFi transfer, which didn’t work until I disconnected the USB cable, then I was able to transfer the file. Yaay!