MINI Wifi Client mode

Hi all,

I received my new MINI today. USB & Wifi Host mode are working just as expected, but I did not manage to get Wifi Client mode to work.

I have set a 4-char long SSID and a 8-char long WPA2-password. The unit performs a reset after I commit this. I then connect to a USB power supply, so the PC does not claim the unit. LED is 2 seconds white, 1 sec off, then 10 sec blue, then constant green. I would expect the MINI to connect to the Wifi at some point, but it does not. The (802.11b) access point is sitting right next to the unit and I have Wifi-trace running on it, so I would see if there’s some problem with negotiation, but the MINI does not seem to even attempt to connect.

Anyone got this to work?
Greets, Andreas

I had to create another Wifi network on my access points. The default one uses a password with 63 characters, which is apparently not supported by the Revopoint.

Maybe changing your SSID (or password) helps. If your access point supports “Guest Wifi” you could use that to play around without disrupting your other devices…

1 Like

The exact same SSID & password work OK when I use them in host-mode. Found out that host mode runs as 802.11a+n, so 5GHz band, channel 56 in my case. I will do some more analysis when I find the time…

This confirms a proper POST (Power On Self-Test) sequence.

I would suggest that you connect the scanner to your computer and verify the WiFi setup. The Host/Client selection is the most important. I configure my Mini and POP 2 as Client, using the SSID and password for my home router. It works flawlessly.

If you are using Host mode, I hope you are remembering to change your computer’s WiFi connection.

Client-mode works now OK for me on a different AP. It seems to not like my dual band AP which may be due to “band steering” or some other obscure feature.

Anyway … I found out that I will probably use USB-mode more frequently, because it is more responsive with lower latency.

I am encountering problems when switching my Mini to host mode. Tried to connect to both a 2.4 GHz and a 5GHz network without any success (both on AP with dual band support). Does anyone have a recommendation what to do? What is the hostname the Mini uses when connecting to an AP?

Thanks for your support.

When the Mini is configured in Host mode, it does not connect to an Access Point; it is the Access Point.

Its WiFi name will be obvious (starts with “MINI”). Have your phone or computer select it.

Sorry for the irritation, I had the mini configured as client. Running in host mode works fine …

I had the same problem, in fact I have two LANCOM accesspoints , on one of them it will not even try to signin, on the other it works like a charm. Same SSID, but different settings.

I would probably be able to track this down by changing settings one by one, but not sure if I will find the time to do this.

Why do you have them configured this way? If you have two access points physically separated and running on separate channels, then you should use the same SSID and PW so that the client can choose which one to access.

Maybe the different settings are different channels? If this is the case then which channel is failing and what country are you located?

It’s in two different “labs”, 270km apart. Each lab has multiple APs, PMK-Caching is used for roaming. I think one lab may have band steering active while the other has not (for historical reasons). It may as well be any other of the numerous settings. I would have to investigate.

Ah that’s interesting. They have the same credentials?
Maybe the Mini doesn’t like the channel shifting.

They connect to the same RADIUS server for auth, so yes, same credentials.

BUT: The failing APs trace shows nothing, no probe request, no authentication request, so no RADIUS message ever sent, credentials cannot be the problem.

The stabilizer – which I received last week - is an incentive to give WIFI client mode another shot. If I find something, I will let you know.

1 Like

Okay, then the next possible solution for the problem you are having is that the SSID and Password for the Home Router (which the Mini will access in Client mode) cannot have any included spaces.

Hi wachovius,
at least this, I can answer: The MINI (Firmware v2.8.33.20220903) does not send DHCP Option 12 , which probably means, that the embedded udhcp-command was started without -x hostname:whatever option . It will however accept a hostname if one is offered by the DHCP-server.

Dynamic Host Configuration Protocol (Request)
    Message type: Boot Request (1)
    Hardware type: Ethernet (0x01)
    Hardware address length: 6
    Hops: 0
    Transaction ID: 0x07898046
    Seconds elapsed: 5
    Bootp flags: 0x0000 (Unicast)
    Client IP address:
    Your (client) IP address:
    Next server IP address:
    Relay agent IP address:
    Client MAC address: AMPAKTec_b1:03:20 (20:50:e7:b1:03:20)
    Client hardware address padding: 00000000000000000000
    Server host name not given
    Boot file name not given
    Magic cookie: DHCP
    Option: (53) DHCP Message Type (Request)
        Length: 1
        DHCP: Request (3)
    Option: (61) Client identifier
        Length: 7
        Hardware type: Ethernet (0x01)
        Client MAC address: AMPAKTec_b1:03:20 (20:50:e7:b1:03:20)
    Option: (50) Requested IP Address (
        Length: 4
        Requested IP Address:
    Option: (54) DHCP Server Identifier (
        Length: 4
        DHCP Server Identifier:
    Option: (57) Maximum DHCP Message Size
        Length: 2
        Maximum DHCP Message Size: 576
    Option: (55) Parameter Request List
        Length: 7
        Parameter Request List Item: (1) Subnet Mask
        Parameter Request List Item: (3) Router
        Parameter Request List Item: (6) Domain Name Server
        Parameter Request List Item: (12) Host Name
        Parameter Request List Item: (15) Domain Name
        Parameter Request List Item: (28) Broadcast Address
        Parameter Request List Item: (42) Network Time Protocol Servers
    Option: (60) Vendor class identifier
        Length: 12
        Vendor class identifier: udhcp 1.27.2
    Option: (255) End
    Padding: 0000000000000000
1 Like

OK, I played with different APs today. MINI totally ignores 2.4GHz band. On the other hand, every attempt on 5GHz band was successful.

Initial guess: Set your AP to 5GHz band and you’re fine.

Ah, just one more little bug: If you switch to client-mode using the PC software, the CONFIRM-button in the WIFI-settings seems unresponsive and you will not see a “rebooting to apply” message. But it will switch to client mode even so …

1 Like

2.4Ghz is to slow for data on the MINI so it uses 5Ghz only

802.11n (“Wi-Fi 4”) does 600Mbit/s on 2.4 GHz !!! I admit, this rate is rarely ever reached because auf band congestion and it’s probably wise to only use 5GHz band as all mobile devices will support it.

Anyway, it should be mentioned somewhere, so there’s no guessing and people do not have to find it out on their own.

It is in Specifications

I saw that and thought it was a misprint, someone transposing 5G cellular with the WiFi listing and treated it as a mistake. 5G is not a proper WiFi specification, IMO… I think the WiFi Alliance might agree with me…

Update: Technically, the WiFi Alliance approved a version of WiFi, defined by IEEE 802.11ac specification as ‘WiFi 5G’. So… on one hand, we could say it’s a correct specification, but I’ll stick with my assertion that, not being complete ‘WiFi 5G’ as well defined string, it’s poorly specified at best.

1 Like