Mini No longer Connects, LED Remains Red

I own a mini and also a range scanner.
I am able to connect to range every known way.
My mini no longer connects to anything and remains led red.

1.) Tried Powering mini by power bank and split cable. No Wireless Connection shown.
2.) Tried 10 presses reset and re power. Nothing different happens.
3.) Led Remains Red
4.) Both cameras seen correctly on USB.
5.) App privacy settings fine

Thank You!

Hi @mpstek

I am surprised that you can see both camera via USB but still the back of the RED is red and not Green .

I think the best thing here is to write to for hardware assistance since you already did everything possible and we run here out of ideas .

I guess you checked my tutorial ?


I will give your tutorial another go round. See what happens.
I’ll contact them then if I’m still not having any luck.


Hello Again @PUTV

I was able to put the unit in flash mode and successfully flash the unit.
I can see 2 usb device and phone connects to wireless.
But still not able to connect software to the unit through either.
I guess I will contact support.


Hi @mpstek

Did you got the green led on ?
Did you tried now the split cable on computer ? It should connect to RS5.4.1

If not please write to and link this thread for reference.

Ok it is stock on reboot , please write to they will help you restore the firmware after you make appointment, sadly after Jan 2nd since the office is closed for the New Year holidays .