Really disappointed in Revopoint. (Mini)

Just wanted to say how disappointed I am with my experience with the Mini so far. Software was updated to 4.1.0, I have 3 usb 3.0 slots and non recognize the device. Blue light turns to green, but the scanning light does not work. Only when I am plugged into the computer and then connected via wifi do I get a picture. Computer sees the turntable in the Bluetooth menu of windows 10, but I never get a chance to connect in revo scan. Basically it is a useless paperweight until everything gets worked out. I’ve went through some of the help section and nothing that I found worked for me. Even being pugged into the revopoint portable power bank, powers on, but doesn’t work.

Some motherboard do not support the power and data at the same time when using just one cable , I have couple of devices that do not works on a single USB cable either and there is not really fix for that as I tried everything possible in the last months while testing MINI , on some computers and laptops it works just fine on others it don’t . Same for POP or POP2

So what I did , I got myself 2 USB extension cables and using now the mobile split cable included in the packet to run the power and the data separately on the same PC and it works all the times .

Regarding the Dual Axis , before I have to click the connect button in the settings 2-3 times before it actually connect . Yesterday my Bluetooth driver update and now it works just fine however it takes a moment to find the Dual Axis under the turntable settings but now connecting just fine .


Hey I just wanted to say think you for replying to the post. I ended up getting it working bt doing what you said and splitting up the power and data. after that worked, I was able to update to be able to connect to the turn table. Thank you for your help!


Thank you Adam for letting me know , Revopoint should made the double/split cable at it’s proper length, it would save so many frustrations , glad to hear it worked for you .