Mini and dual axis turntable

I have just received my Mini and dual axis turntable. Software says I have to update the firmware, but that just hangs.
From this forum it appears that the firmware to make it work has not even been released yet.
Is this true?
Is Revopoint selling things that DO NOT WORK !

I’m sorry I don’t have a solution but it did work for me. Do you have the new beta of Revo Scan? Maybe it needs to be connected via USB.

Well it all worked perfectly for me , and I was able to upgrade firmware on my 3 devices without issues .

So please don’t be so quick in your judgements. The hardware is not broken after all .

Be patient, they working on the solution for those that was not able to upgrade their firmware .

Some users are blocked from connecting to China’s server while upgrading and need to use VPN to trick own internet provider etc …

You also need to process the upgrade via USB only .

Search the forum for more information and look for new updated official software, the beta is already outdated .

1 Like

Your naivety astounds me. You must have more money than sense.
When I buy a product I expect to work from the box. Not at a later date when they have written the software.
In our country selling product that they know is not ready for market is a serious criminal offense.
As it was an hour after I posted to this forum I received an email from Revopoint saying they had uploaded the NEW software to the web site. And that this software would fix the firmware issue.

So my statement still stands. IT WAS NOT READY FOR MARKET.

I will now find out if it DOES work.

In the future I will not trust Revopoint and suggest you do not follow them so blindly.

Hi,
I am sorry for the inconvenience.
We are working on solving some problems. Some users gave us the feedback that the software stuck in step 2. We will soon upgrade a new version. Before that, please check if solutions in this link help.

PUTV’s opinions are indepent and based on her experience, which the software does work with her devices, just like other users. We appreciate our users to communicate and share your opinions peacefully here and respect others. Thanks for your patience and understanding.

2 Likes

Did you buy a retail version or did you buy from Kickstarter?

What kind of work to you plan on doing with your scanner?

I received my Mini Wednesday afternoon and unboxed it Thursday morning. It fail to update the firmware the 1st time but I hit the button again and after a few minutes it was successful.

I ve a have POP2 and Mini both kickstarter’s . From what I observed over the last few month is Revopoint is trying really hard to produce and provided a inexpensive product for scanning. Yeah there are some glitches but their turn around time on product development is insanely fast and they have this whole community to help flush out the product.

@gtcnetworking things will pan out , Revo point will not leave you hanging. In the mean time you a dollar store lazy Susan and practice your scanning techniques, There is a lot of nuance to the process.

Best of luck on your 3D scanning journey.

1 Like

OK we have moved forward and then got stuck again.
I downloaded the latest 4.1 software and now it updates the firmware OK.
No problem updating firmware - worked first time.

BUT
now when I try and pair the turntable it sees the bluetooth device and allows me to add it.
BUT when I click on CONNECT it sits there for a miniute or so and then fails to connect

I have tried restarting everything. PC included. I can remove the device and search and add it again and again. But it doe not CONNECT !

What now Revopoint ?

ps. I purchased retail from revopoint. Not kickstarter.

I dear we are going backwards
I gave up on the turntbale and went back to trying scanning.
Now since I updated the firmware and software I cannot scan anything.
I could before. but now the preview shows nothing. Blank screen
No matter whate light setting I use.
The RGB works and the depth camera works but the scanning see nothing.

Revopoint - YOU HAVE TO FIX THIS !

I have a completely useless piece of junk here!

I tried your suggestion Tin WHisper, but since I updated the firmware it no longer scans anything.
RGB camera and Depth work but preview and scan do not see anything.
At least the scanning worked before I updated the firmware.
Now I have a BRICK

it is a piece of rubbish !

Maybe returning it is your best option.

By the looks of it they have a 14day return window in their return policy.

The banner also scrolls with " hassle-free warranty" but I could not find any info on thier warranty. @Revopoint3d-Selina Do you have a link to your warranty policy?

1 Like

Sorry, we are off work during the mid-autumn festival, so I wasn’t able to reply to you instantly.

Please for Bluetooth connection issues, please close the Bluetooth on your computer. And then restart the scanner and the turntable again, delete the “dual-axis turntable” on the Revo Scan screen, search again, and connect.

For the scanner problems, please provide a video showing them. So that we can check out.

If you need to replace or return the scanner, please contact customer@revopoint3d.com. Our team will be there to help.

Thanks for your understanding.

Thanks for the reply. Here is the link.

Good news at last
After a long zoom session with a rep at Revopoint I have a working scanner AND dual axis turntable.

So they DO work if a little fiddly to get setup.

Now to scanning and see how well it performs.

2 Likes

Dual axis turntable not working with iphone app?
How can I start rotation manually?
It doesn’t even work on PC with pop2.

Sadly it is not working yet with Android or iPhone app .

But our community members creating an app actually @Johnathan is doing it now for Android for manually control so it may be early than the official one from Revopoint .
Check the forum

1 Like

Works with pop mini on iMac

1 Like

You are right forgot about the last release for iMac.
I can’t get anything on Windows with POP2 despite the fact that I have the last firmware updated .

Just got my Mini and the dual axis turntable due to work commitments did not open parcel for 5 days I spent the last 2 days trying to update the firmware from being stuck at 20% I only have 4 days left to decide whether to send it back for a refund, did not expect this sort of problem