Inspire Troubleshooting Connection

So I just got my Kickstarter inspire. Got the Revo Scan software downloaded (5.3.0) and got everything hooked up. Scanner powers up and light turns green but Revo Scan shows “Scanner Disconnected” I have tried every USB port on my computer (motherboard is an ASUS ROG Crosshair X570 VIII Hero Wi-Fi so plenty of USB 3.0s to try). I also tried connecting to Wi-Fi. Computer connects fine and shows connected to scanner Wi-Fi but Revo Scan still shows scanner as disconnected. I literally cannot do anything with it as the software just tells me to connect it if I try to calibrate or create a new project. How am I supposed to get this thing connected since the user manual is lacking to say the least? Any ideas? Also the unit warms up rather quickly.

I have one question

How you powered your INSPIRE when you used WiFI connection ?

Please use the split cables and USB A go to power supply ( not your computer ) once the green light shows up connect the scanner to your Computers WiFi

Then open Revo Scan again and see if you get connection , the second led on INSPIRE should turns blue .

Let me know if it worked …

If not?

pls contact because it will be hardware issue and I can’t help you much from here .

Using the mobile kit power bank with the split cable that came with the other kit I bought from you and using Wi-Fi does work. Thank you for that. Now how do I get it to connect directly to my computer with the included USB cable? As this purchase was intended mostly to be used to scan parts on the turn table.

Also while you are being so nice. My Scanner Handle has a sticker on it that says the “Tripod can extend up to 30 cm.” How do you get it to extend, mine only seems to just go form handle to tripod mode by opening the legs, but I do not see a way to extend the legs like on a traditional tripod.

You can use Wi-Fi to scan , the quality and speed is the same .

From what you saying it seems like your computer USB ports or MOBO can’t support power and data on one cable at the same time when using Revopoint device, trust me my very expensive PC can’t do that either and there is no fixation for that . Some motherboards support it others don’t .

What you can do instead , you can buy USB extensions to use with the mobile split cable and connect both to your computer , that’s how I do .
This way data and power will be supplied on 2 cables that allows you to direct connection to your PC , but trust me WiFi is as good .

That all all option available here for you at this moment .

Regarding your tripod , I don’t know what kind you got , usually you can pull the neck to extend the tripod , if the legs have a seam then you can pull it out , if they are solid then only the neck can be extended…

This is my mother board : ROG Crosshair VIII Hero | Motherboards | ROG United States

It has 8 ports at 10 Gb/s for a grand total of 12 ports at USB 3.2 which is well over the recommended 3.0. Not sure how this would not be supported. As for my cpu I’m using an AMD Ryzen 5950 and GPU is a Nvidia 3090. Motherboard has no problems running my three monitor’s built in usb hubs, usb powered microphone I use for gaming as well as my mixamp for my headset, also usb powered with audio I/O. Even my keyboard requires two usb cables because it has a usb pass through on it. This doesn’t even begin to list the other devices such as my laser etcher, 3d printer, etc…Needless to say I have a lot plugged in. Even unplugging all that, this device still cannot work as intended. What a bummer. As for the tripod it’s the one that came with the inspire.

I still don’t agree that it is my computer being incapable of running the device, but for the purpose of the argument, let’s assume that it is. What if I buy an expansion card such as this ThunderboltEX 4|Motherboards|ASUS USA

It supports 40 Gbps bi-directional data transfer (so 80 Gbps) as well as has the ability to supply 100 watts of power through the same port. The inspire only requires 5 watts, so that should more than suffice to power and provide data. There is nothing on the market that can provide more data transmission along with that kind of power. I refuse to give in to such a meaningless thought of production and assume that the manufacturer would create a device that in the quick start manual says can run on a single cable, yet does not allow it to run on a single cable.

Sorry @TheNgbaka I don’t say you have bad computer … the thing is that some motherboards will not support it , I don’t really know if that is the driver or under powered USB , there is really not fix for that other than 2 separate cables .

Meaning your motherboard don’t want provide proper power and data via one single cable at the same time , there is enormous data files provided via the USB in real time that not one of your home device actually works at that capacity .
For some reason the huge amount of data and power can’t pass through to the system . There were many that tried to find solution for it and failed.

I tried everything even contacted the manufacturer of my MOBO without any good results .

There are cheap laptops that can support power and data via one cable from Dell , but a expensive motherboard can’t … it is mystery why this is happening … it maybe be windows system in combination with the motherboard… it can be anything .
On one system it works or other it don’t and there is no clear solution why one system works well and other don’t .

So buying additional stuff will not guarantee anything .

For example my Dell latitude Tablet PC can support INSPIRE via one single USB cable but my 1OK PC can’t … I seriously stopped bother with it …

Just get 2 extension USB cables connect to your PC and that is … it will works the best way it can .

Thanks for all the replies. Last question… I hope. I have taken the split cable and plugged them both directly into my PC, one in USB-A and one in USB-C, with the USB-C (screw supported side) plugged into the Inspire. That doesn’t work either. I can only get it to work if I use the battery power supply that came with my mobile adapter kit. So my question is, exactly how do you have yours connected with two extension cables?

It looks like there is issue with the power supply from your computer .

I have 2 USB extensions plugged to my computer just the way you did and works just fine just with 2 extensions and the split cable

It is possible your computer’s USB don’t want to support the proper power level to INSPIRE for some reason … what make sense why the single cable don’t works either

You can use the split cable , connect the USB A to power bank or 2Am charger and the USB C to computer for the data only .

You saying that when connecting to the battery it worked right ?

Split Cable
USB A to battery power bank or 2Am charger
USB C to computer for data
Start Reco Scan
Make sure 2 led are on on INSPIRE after connecting

If it works then the issue is only with power supply from your computer port , you can check the USB settings on your computer under Power Settings to see if the USB ports are set to conserve power or run at full , maybe it can help .

I find it hard to believe it is a power issue since I have 9 other items plugged in all at the same time powered over usb with no issues, especially since the inspire only requires 5 watts. My current power supply is a 1600 watt corsair AX1600i 80+ titanium.

To answer your question, yes if I plug the inspire into the battery bank with the data cable into the pc it works.

On the flip side, my pc powers on the inspire with no issue, it just won’t have a connection. At this point I have submitted a ticket with revopoint for further diagnostics.

Here is the USB Device Viewer info from the windows debug software:

===>Configuration Descriptor<===
bLength: 0x09
bDescriptorType: 0x02
wTotalLength: 0x0273 → Validated
bNumInterfaces: 0x05
bConfigurationValue: 0x01
iConfiguration: 0x04
English (United States) “uvc”
bmAttributes: 0x80 → Bus Powered
MaxPower: 0xFA = 500 mA
===>Class-Specific Video Control Interface Header Descriptor<===
bLength: 0x0D
bDescriptorType: 0x24
bDescriptorSubtype: 0x01
bcdVDC: 0x0100
wTotalLength: 0x004F → Validated
dwClockFreq: 0x02DC6C00 = (48000000) Hz
bInCollection: 0x01
baInterfaceNr[1]: 0x01
USB Video Class device: spec version 1.0

So I still don’t believe it is a power issue. However I did find that my usb protocols are not configured correctly for the 3.0 spec. Attempting a remedy on that now.

I see many people attempting to find a solution for almost over 2 years including manufacturing companies that had no clue why it is happening … wishing you a good luck !

Who knows maybe you find a final solution !

My PC can’t hold steady connection via just one cable USB A or C
But it works perfectly using 2 cables

Thank you and I sure will try. My issue at this point hearing from you is actually with revopoint themselves. They are advertising these items and even have in their manuals that they can run on a single cable. This would be bad for their business image to continue advertising as such. Unfortunately for me I was an early adopter and got mine off kickstarter so I am unable to return said product. Lucky it’s not a matter of money. I will however no longer be buying anything from revopoint on a matter of principle in false advertising and will insure all contacts in my network follow suit to include all county school systems I have input for with their respective technology departments. Thank you for your assistance but you obviously don’t work for revopoint and as of now their customer service has also been non existent.

Hi @TheNgbaka

That issue has nothing to do with Revopoint or their product , it is purely related to individual systems .
On one it works , on other it don’t …

After all your system can’t support it so you can’t blame someone else for it .

Why it works on my Win Dell Tablets PC and not on Desktop PC is truly a mystery , it may be windows related or my MOBO , but it don’t give me right to blame Revopoint for it , they ding build it , I did …

You tested it already , and you saw for your own eyes your system can’t support enough steady power and data on the sane time . Yet it worked fine with battery power support .

There are not 2 equal systems in the world but I believe the motherboard is to blame , since even the manufacturer of my motherboard could not answer me the question .

I suggest you try the single cable on your friends computer and see for yourself .
I have 2 other and works just fine … only my Desktop PC don’t … the other are Dell and Asus …

I wanted to thank you for constantly replying. I have, however, fixed my issue and am now able to use the device with my computer on a single cable as intended. I did want you to know that it had nothing to do with the available power my system has, it had nothing to do with my MOBO not being able to support data and power at the same time. It is not too constructive to constantly tell me what you think the issue is/was and continuing to stick with it. Usually in the PC repair world, we test and test again and keep working to a solution until we are certain that a piece of hardware needs to be replaced. It did however have everything to do with a simple windows setting that most probably will not think to even give a second look because it is so simple of a fix that even I overlooked it for some time. So for anyone else reading this having the same problem, have a quick look at what “desktop apps” have access to your computer’s camera. Toggle on and try again. If that doesn’t work, you could then go through the numerous steps that I did which involved trying every port, testing every cable with a line card usb tester (if you have one), going through your windows registry files for any anomalies, checking firewall settings, running power and data test for your usb ports, verifying bios legacy settings, flashing bios, etc… I did however have fun pushing your buttons, but please do not pick one solution and stick with it when attempting to help someone. Thanks again.


Awsome that you found a fix, better that you shared it. Just making your solution clear for others searching.

Thank you , but this don’t fixed my issue at all as it is not related , but I am happy to hear it worked for you .

From your early information it sounds like power issue what is very common in 95% of cases . Since your scanner worked when using additional battery but not when connected to your PC so that was typical power issues .

Of course you have to give also camera permission on your system but everyone knows that .

Anyway glad you can use it again

Hello everyone,
I had the same problem with my desk computer.
you need to enable permission for applications to connect to the camera, so that the scanner connects.

Hi @etienne13 , yes that is also one of the issue users encounter with connecting the scanner
there are also one that people overlook sometimes like required 5G WiFi on phones , laptops or computers