[Android] Dual Axis Turntable Controller app v.5.8 | Android 5.1 to 13

@Johnathan next test. Result the samen. Old version deinstalled. New installt and started

I also get the same error on my Samsung S21 ultra on android 12.

Johnathan located the source of the issue already .
He will post some fixes soon for the Android 12 users.

Others can use the current version on android 5.1-11 for now .

2 Likes

can someone with Android 12 test this

link removed NEW Version in first post

1 Like

Ok i had testet


Edit: App rights for units in range i had activated manual in app after installation, but no change by error message.

Ok then it will have to wait until I can get an updated library for BLE as I have tried all the options to manually get round it in this version, the current BLE library does not support Android 12

For now Android 12 & above are not supposed

3 Likes

@Johnathan Ok, no problem. Thanks for your work.

1 Like

Hi @Johnathan, do you have a Github / BB repo with the code you could share. I have an Android 13 device (PIxel 6) and used to be a competent mobile developer once upon a time. I may be able to get it to work locally and contribute back to the repo.

//James

I have done this little test app to see if it fixes the problem before I have to redo the whole thing
can people with Android 11, 12, 13 test it please and show your results

thanks

It worked! (Pixel 6 Android 13)
I could approve the bluetooth permission and connected to the DATT.

1 Like

excellent that gives me something to work with!
can you do a screen shot so I can what it’s showing just to compare it to what I see on my lower Android versions
thanks for the help

1 Like

@JamesR can you test this version for me please

link removed NEW Version in first post

1 Like

Still does not want to work with the main app.

Here is the from the test app.

@Johnathan The test app


But the DATT app

I had an error in the last one sorry please try this one

link removed NEW Version in first post

Clicking this stops the sequence program and returns to zero
edit: check now version has been changed a little

1 Like

Ok it connects and i think it works now. Congratulations. :slight_smile:

1 Like

cool thanks, simple mistake made a difference to 12 and above only, bellow still worked lol, now it detects the version it’s using two different bits of code to connect the Bluetooth

thanks for the help :+1:

2 Likes