Windows Revoscan and revostudio issues


Windows 10 laptop
I5 intel
UHD 620 graphic
8GB Ram

I have downloaded the newest versions of Revo scan and revo studio.

Revo scan: Starts but preview is Black. The small two screens show picture. one in color the other in Red.
As soon as I press new scan it closes the program completely. I tried different settings and new Graphic card drivers. Its Intel UHD620 but no changes. It crashes every time.

Revostudio: icon shows on taskbar, but doesn’t open software. it took CD-Key and the emailed code, but then never starts. After some time where ever I click on the desktop it opens a window to select a file (opj.ply.) but software doesnt open.

Would you have a tip for me? or maybe a previous version that I could Try?


The red screen in the Depth Camera window means that the Gain setting is too low or too high.

Aim your scanner at what you want to scan and adjust the Gain throughout its range. If you cannot find a setting where the object is shown in gray scale, then the explanation is probably that too much infrared light is shining on the object.

You might try turning all lights off and scanning without color to see if you can get some usable results.

Also, it would be helpful if you posted a picture of the object you want to scan.

It should not close the program even if you have not enough points to scan , you should get just a note , but as Jeff stated already lower the gain under the red window until you see the object in dark gray values .

I am not sure but it seems like software issue on your system , try to start the programs as Administrator . Also if this don’t works search for **Handy Studio ** and Handy Scan 4 in the forum here, that are early more stable versions that still works just fine .
It will helps you at least to practice until other issues get solved.

Just always remember to set the proper gain value under Depth Camera window , that is the key for a perfect scan results . Stay away from bright windows light and infrared based devices , I even noticed that a simple remote control affected my scan creating a flash point , and windows lights have a lot of infrared lighting that even can affect your TV remote controller.

Thank you for the replies .

The Depth camera seems to work, that’s what I was trying to say with the picture is showing.

The Program is shutting down when I press new scan. I feel like PopUpTheVolume is right. it does seem like the software doesn’t cooperate with my laptop. I have run it as Admin and same issue.
It’s just weird that both studio and scan don’t work on my laptop.

how does the Pop2 show in device manager?

I will try looking for the handy scan 4 to see if that works.

Thank you

The device manager shows it under Cameras you will find 2 camera one is RGB and Depth Camera .
I saw others having this issue , but it is very random and nobody really knows what is the reason .

If this is software issue then you will run Handy Scan for sure , if Handy Scan don’t run then there is another issue on the hand . You can try to find even older versions if you can , how older how better for this test

1 Like

The Device manager shows 2 cameras. RGB and Depth.

I have installed Handy Scan and it works. I guess I will be waiting for a different version of revostudio if I cant find a way to make it work.

Thank you

1 Like

Start Windows Performance Monitor and then try again. When Revo Scan shuts down, quickly switch to the PM screen and look at available memory. It it maxed out, then had a quick drop, than I’d wager you need a memory expansion.

@Waldemar Handy Scan is much lighter version as was Handy Studio ( but somehow it vanished from my download folder ) and can’t find Handy Studio software anymore in the forum , I mean the older one from January .
There is plenty of other programs that can fuse your partial scanned meshes , so not that you are in stand still you can use Meshmixer,MeshLab, Cloud compare and other great software to do more .

Handy Scan has a very nice point cloud fusion results , I like to use it more often now

@JeffLindstrom that maybe sometimes an issue as well , but Waldemar can use Handy Scan as well so something different is on the hand . Clicking a scan button and crash don’t looks like memory issue. However we don’t know how much RAM Waldemar is using in his system so hard to evaluate this issue based on speculations , and I saw others experienced it as well .

The other day my Revo Scan was using 8GB of memory while scanning detailed object , and Revo Studio can get really aggressive with the memory especially with 46 millions poly models .

I searched for “Handy Scan 4” and was only able to find “3”

Can someone post a link


Gerald the name is or exe , I got it on April 14 2022, but the original upload date was on February.17.2022

I get “No results found”

@Miamijerry sorry it is gone , I can’t find it anymore even Handyscan 3 is deleted

My suggestion was to verify or eliminate available memory as a possible cause. No one else had suggested it, but it is a possible cause.

As for him being able to use Handy Scan, remember that it is designed to work with the original POP, so a pitch that is three times as large as possible with the POP 2, so (approx.) three times less memory required.

@JeffLindstrom my pitch point settings in Handy Scan are at 0.05mm the lowest Handy Scan 4 is the same as Revo Scan 4 both works with POP1 and POP2

I saw today another post someone said changing the Nvidia Panel graphic card settings stopped the software from crashing . That is maybe an answer for the mysterious question .

Thanks everyone for the tips.

I have 8Gb Ram on there. I have found a different driver for my gpu ( an older one) i will try that tonight.

I did the analysis and it doesnt spike. but it shows handyscan.exe using 54% even though thats off. I thought that was weird.

@Waldemar Handy Scan using lots of power , it captures 10 frames per second , sometimes I am ending with 4000 frames so lots of power needed to capture it and process it in real time . There is a new Windows Revo Scan software available today , very good , download it and check it out .

Your graphic card may be the issue as Revo Scan creates more dense point clouds as well , go to your graphic card panel and change the 3D preview to performance in place of quality , it may help .

It works now.

I had Kinect developers kit installed for the Kinect sensor. I totally forgot about it. uninstalled everything and restarted. now with the new version everything works. the scans look better with revo scan 100%

Thank you all.


Don’t be surprised if you still encounter memory issues when doing large scans and meshing large scans. 8 GB isn’t really enough memory for this…

1 Like