RevoScan crashes on launch with my MINI

Last week I finally received my Revopoint3d mini with turntable. My PC runs windows 10 pro v21H2. It has 32GB Ram and 1TB solid state disk. The processor is an AMD Ryzen (64bit)Embedded with Radeon Vega Gfx 2.00 GHZ. Revoscan version is your latest according to your facebook page, namely revo_scan for win_v4.1.0.20220905c.

I tried direct connect to my USB3 port on the PC as well as connecting via WIFI and powered by external 5v USB power supply. I have installed/uninstalled/reinstalled the revoscan software several times. I get a green light on the scanner.

Each run on the PC, the screen turns all white, cursor circle spinner spins for a few seconds, disappears, then starts spinning again. Shortly after the second spin the white window goes away, indicating the program crashed.

Scanner runs on my Galaxy S22 Ultra with your android app, so scanner checks out as “working”.

I noticed from other posts that OpenGL 4.0 is reqiured but I do not know if this embedded graphics coprocessor can handle it.

Please advise.

Yes your graphics processor can handle OpenGL 4.6 and OpenCL so there should be no issues with that .

I don’t think it is the graphic card but …
Do you have any other graphic card running on your PC ? You know that you can easy switch the OpenGL to your other graphic card by right clicking the program icon and choice where to run it on , just to see if things works or not .

If still the same problem then you will have to wait until the Revopoint support team returns back on September 13th from holidays to assist you with this issue.

Your scanner is working so that is not the problem , but there is something preventing the program from starting .
Did you tried to open Revo Studio ? To see if that works? If it works then definitely not a graphic card issue here .

I am sure @Revopoint3d-Selina find for you solution once she is back at work .

While you shouldn’t have a problem (OpenGL 4.0 was released 12 years ago, after all), you might want to try an experiment and disable hardware accelerated rendering.

After returning to the Preview window, exit Revo Scan, reboot your system and see what happens.

Would you please record a video showing the problem?

Jeff the software don’t even starts to adjust the settings … you missed the point
You would be surprised how many users trying to use their old laptops that do not support OpenGL 4.0

Maybe… maybe not. Depends on how the software implementation of the OpenGL driver was written and also how Revo Scan accesses the GPU with that switch activated.

And it’s a simple enough check.

So how you propose to adjust settings in a software that don’t even starts ?
How someone can do that with a closed software ?

Try Safe mode. It’s a gamble, but may work.

that at least something … :wink:

Also, try running the program in Administrator mode.

Slightly more involved is to uninstall Revo Scan, reboot, re-install Revo Scan in Administrator mode, then run it in Administrator mode.

1 Like

None of these suggestions worked. My AMD Ryzen board is in a UDOO BOLT with no expansion slots. I gave in and bought an HP Victus 16-E0085NR laptop with 16GB RAM, 512GB SSD. Installed revoscan and ran a brief test. The MINI scanner works so I think I’m out of the woods. I still need to test the dual axis turntable. Thanks all for the suggestions. I hope this works. Still awaiting the scanner spray.

1 Like