[Tutorial] How to connect the POP 2 to your Mac via Wi-Fi Host Mode

  1. Plug the POP 2 into a power bank or AC adapter. (Do not plug it into your Mac)

  2. Find the Wi-Fi name from your Mac’s Wi-Fi list.
    Usually, it is POP2-REVO-A21AXXXX. And enter the password - Revopoint3d.

  3. After the Wi-Fi is connected successfully, open “Revo Scan” and wait for a while for connection.

  4. Then, you can click “New Scan” to scan the object.

Best Regards
Cassie

1 Like

Can I change the wifi ssid and password?

Hi @PandaBall ,

Yes, you can. I will make another tutorial soon.

Best Regards
Cassie

1 Like

Followed these instructions and it will not connect. POP2 is connected to a USB Power Battery, the LED is green. My Mac is connected to the POP wifi network properly. When I open Revoscan 4.0.0.0307d mac wifi beta, it just sits there and never connects.

I tried on Android (Galaxy Fold 3) via USB and WiFi. It just crashes each time I try with USB and WiFi connects and it sees the POP with correct serial number, but nothing happens. Just a black screen.

Not a good look when new product doesn’t work on Android or Mac…

Disappointed.

Hi @exr90 ,

Sorry for the inconvenience caused.

Just confirm, may I know if you use a high-power range extenders for your home Wi-Fi? We have a beta tester @jumbonot who meets such a Wi-Fi connection issue. After he turns off the Wi-Fi extender, the problem was solved.

For Android via USB, did you plug the power cable to your phone directly? If the power is not enough, the software will crash. You need to use the mobile kit. (I will post a tutorial later).

Best Regards
Cassie

1 Like

I am connecting directly to the POP wifi from my Macbook. I am not connecting to home wifi.

I have the included mobile kit, where it plugs into the POP and has two cables hanging off it, a USB-C and a USB-A. I plug USB-A into power brick that puts out 2.1 amps max, and the USB-C into the phone.

Sorry for interrupting, but does the Macbook recognize the USB connection? I don’t use Ios, but I had similar problems with my android phones and the USB method. Just curious about the Apple end of things, since I do have an ipad. Thanks

Unclear, nothing of note happens upon plug-in via USB.

The native mode of the POP is USB, powered through the USB 3.0 or the USB-C cable supplied with the device. Have you been able to use the USB-C to micro-B that came with the POP labelled “for computer” with a desktop?

Hello Revopoint Team,

I tried this method on my windows 11 machine, hoping to connect it via WiFi, but it doesn’t seem to work.
The Pop 2 is connected to the powerbank adapter and opens a WiFi network, which I can connect to on my Windows 11 PC. But if I then open Revo Scan, it says no device is connected and does not indicate that it is in WiFI mode at the bottom bar, like in the tutorial.
Do I have to change some settings somewhere or should it recognize automatically it is in a “Revopoint Network”?

Best Regards
Luca

I can connect to the POP2’s WLAN but the Revo Scan app doesn’t find the scanner.
MacBook Pro directly powered via USB-C from the MAC

Does not connect to the iPhone. Keep getting check connection. The about button in the software does not access the wifi

Hi @Krummrey ,

Please kindly power the POP 2 with a power bank or an AC adapter, rather than plug it into your Mac directly) – because if you plug it into your Mac, the software will choose the USB mode first.

image

Best Regards
Cassie

HI @lcjng ,

Is it possible for you to share us a video to see more details about the problem? Then we may find the reason.

Best Regards
Cassie

Hi @GKS ,

Is it possible for you to share us a video of your connection steps? You can send it via a private message if you don’t want to show it in public.

Best Regards
Cassie

1 Like

I must admit, I just got it working, after trying it again, here’s my approach & solutions:

I mistakenly used the 2-in-1 mobile Cable to connect the USB-A Port to the supplied powerbank, which did not work.
Using the Micro USB-B to USB-A Cable and pluggin it into the Powerbank DID work howerver and it was detected by Revo Scan which then set itself in wifi mode.

So that solved my problem

2 Likes

Hi @lcjng ,

Thank you so much for your updates. It may help other users.

Best Regards
Cassie