The device does not support the current precision

Hi, I copied the directories from my android phone where I made the scans (This PC\Mi 9T Pro\Internal shared storage\Android\data\com.revopoint3d.revoscan\files\RevoScan\data) to my windows 11 pc. I then imported the directories into Revo Scan and when I want to open them I get a warning dialog saying: the device does not support the current precision. They work in the Revo Studio though.

1 Like

Was your POP connected when you tried this? It only supports to 0.3mm. If you had fused the point cloud at 0.1mm and then tried to use it in Revo Scan while the original POP was connected, then that could explain the problem.

Thanks @JeffLindstrom
No the POP 2 wasn’t connected to anything any more. My plan was to scan on the phone, copy the files to the PC and continue with the workflow in Revo Scan on the PC. I get the error on the PC

The phone is set to:
accuracy - fast mode
scan mode - head
texture - colorful
export file format - ply

For most of the scans I copied I did perform the fusing (fuse point cloud immediately) on the phone but nothing else.

This is because the POP 2 was not connected to Revo Scan. I expect that, even if the original POP was connected to Revo Scan, it would not allow the file to be opened if it was created at a higher resolution than the POP was capable of providing.

I did open a Body mode scan taken with the POP 2 while the POP was connected, but it was Fused at 0.9mm, which is well within the POP’s capabilities.

This is a bug that I will bring up with support.

1 Like


I am going to do that today and see if it really works or not as I plan to scan outdoors with my phone and want bring it back to PC after for meshing , of course you still have Revo Studio that offers better meshing parameters than Revo Scan .

I will let you know if that worked out .

I was wondering about that, as my scans on the phone are nothing than on my PC , smoother , less details and accuracy . Does this mean the phone fuse it at higher value settings than PC software ? since we do not have the fusion option on the phone I was wondering for days now why …What is also the standard setting for meshing on the phone ? because everything looks like on 4.5 with 3 smoothing for meshing.
Also the point cloud preview on my phone looks very much reduced in quality compared to PC, not matter high or low accuracy.

1 Like

Ok @Robin

This was the point cloud I just fused on PC via Revo Scan , I can’t open it again
why not ? because your POP2 is not connected to the software on your PC , once you connect back POP2 on your PC you will be able to edit the point cloud data again using Revo Scan and mesh it or even add another cloud point and fuse it together .
Screenshot 2022-04-07 055125

1 Like

Try it in Revo Studio. It does not expect a POP to be connected.

It working fine in Revo Studio , no need for POP2 to be connected , but sometimes I do like to add some data if I am missing something especially when capturing color , but once you connect back POP2 things works fine , also you can open the files via the tab where you select the new scan modes .

1 Like