[SOLVED] Use 3DViewer? Do not update camera firmware!

I hope this is helpful to someone; I am already in contact with Revopoint support about the issue.

My POP3 was working in 3DViewer; I was curious about the new RevoScan update and ran that; it prompted me to update of the POP3, which I did, hoping for better performance, possibly.

Unfortunately my POP3 does not connect anymore now in 3DViewer.

The firmware updates are needed to unlock new features of the hardware , if not updated , the software can’t access it .

Having better scanning experiences or not… that’s the choice you made here…

The priority is Revo Scan 5.3+ , it is not intended to use with other software …

Be aware of your choices .

I’m not sure if you understand what I’m talking about.

3DViewer is a Revopoint application used by developers like I am; this is why I posted this in the Developer subforum.

Right now if you update the POP3 firmware, it will not work anymore in 3DViewer.

You probably have to reapply the hardware unlocker

Ah ok … they will need to adjust the application in this case …

Still the point of updating the firmware stay strong …
I wish you were informed before about the changes at least .

1 Like

If you mean the RevoLicenseWizard for authorization: tried that. It authorizes successfully but still the camera connection in 3DViewer fails.

Thanks though for the suggestion.

any update to this issue from your email to revopoint?

I am in contact with Revopoint; the cause of the issue is not clear yet. From the 3DViewer application log, it seems that the camera authorization may have coincidentally expired right about the time I updated the firmware; re-authorization has not been successful however. So no solution yet.

if the license expired the serials need to be rearmed by Revopoint to work again.

It seems that they have tried that, but to no avail.

Happy to report this issue has been solved: it turns out the camera authorization had expired right around the moment I updated its firmware; to get it re-authorized an update of RevoLicenseWizard to version 1.0.10 was necessary.

1 Like

So the title of this topic is outdated now; unfortunately I can’t seem to change it myself?

@PUTV can you update the title to resolved?

Awsome, thanks for the update Master