Revo Scan 5, POP 2 update issues

I downloaded the latest Revo Scan V5 on my win 10 computer, I tried to update ( expecting there was a new firmware since last year, but I keep getting an error message.
“Failed to find the latest version, unable to detect the latest version because of no network connection.”

Ive added Revo Scan to the firewall exception list for private and public, I even turned it off. times out so that didnt work, but I have a network connection. The scanner works and connects as it should in Revo Scan, so no issues there either.

One quick check would be to turn off the Firewall.

I tried that also, just to be sure. Even checked my router, and no firewalls there either.

Hi @homestead_us in some cases your network provider is blocking access to China servers so it may be not your computer setting issues but your Network provider restrictions .

What others did in this case is using VPN

If you can’t figure it out please write to they will help you out with the hardware updates of your device .

I’ll give that a try later today, thank you.

The VPN solution worked, thank you PUTV. Now, my only question is the POP2 is still on the same firmware from almost 2 years ago (, I expected to see an update of some sort based on other posts and firmware references. Was the POP2 abandoned in favor of the POP3 and other scanners?

Hi @homestead_us

If there are features that need to update the firmware it would update , but right now everything works optimal .

If there are not update for your device it means it works optimal with the current software .
If you saw some other updates it means the other batches needed some fixes , don’t means your device need that too .

Recopoint never abandoned any scanner and the there is lifetime support .

If you have any serious issue with your hardware , the technical team will assist you via .