[Solved] USB under powered it seems

Just received my POP today. Followed the user guide to get started. The green led light comes and it shows video in the HandyScan app, but the red “projector” light doesn’t come on or barely does. Seems the POP is WAYYYY to finicky about which USB port is uses. Seems most usb ports are not supplying enough power. Revopoint, you may have to provide POWERED usb hub for your backers!

Hi, @Fireslayer26 The USB port should be USB 3.0. If it is USB2.0, it can’t provide enough power supply.

I bought a powered USB 3.0 hub and it still did not work for me :frowning:

@Revopoint-Cassie I have tried every 3.0 port on my PC with same results. It also would not work when plugged into my USB-C port on my phone. It looks like others are having power issues as well.

Can you verify how much current is flowing to your device? I think discussing it here is just a theory without any data.
If only my device had arrived, I could have tested various things, sorry.

Yes, measuring those for whom it works and the others. I have one of these usefull devices to measure power, only missing the POP :sweat_smile: :sob:

The POP works well from the USB port on my Dell laptop. Haven’t tried it from the portable USB recharger yet.

Hi @Fireslayer26 @mrehmus @Nebulus @KnightRid @yaki Here are the details:

  1. The peak current when POP powering on is about 0.95A;
  2. The peak current when POP starts to scan is about 1A;
  3. The peak current during POP scanning is about 0.95A;
  4. The peak current when POP is powered on but not scan is about 0.75A;
1 Like

Hi, @KnightRid, I had asked the product team about your issue with USB 3.0 hub and will tell you once I got a reply. I remember that your POP is working when connecting to the phone, so I guess the problem should be the powered USB hub. May I know if you tried to connect the POP directly to your PC’s plug? Not via a USB hub?

1 Like

Hi @Fireslayer26 1. Could you try to connect the POP to your iPhone to see if it can work typically or not? 2. Could you let us know your PC’s spec so that we can analyze what’s the problem?

Sorry it took so long, my wife had surgery 2 days ago so it has been a little hectic around here :wink:

Yes I tried on my USB 3.0 AND 3.1 ports on my computer and both did the same thing. The powered hub I got was this one - https://www.walmart.com/ip/onn-Powered-USB-3-0-Hub/325592700 - since that was the only one they had. If you zoom in on the pictures it says it supplies 900mA per port with the adapter plugged in so maybe that is still not enough.

I have been so busy with her that I have not ordered to Y-adapter yet to test. I hope to get to that today and have it early next week!

This problem is solved by this method: [Tips] Remember to check the camera permission of your PC