POP2 Failed to get the cameras information


My brand new POP2 worked fine for one day. After that I get the message "camera exception. Failed to… etc etc… both on computer and over WiFi

I have checked that the app is allowed to use the camera, tried all possible cable setups with both single and dual cable and restarted everything countless times.
I tried with an external USB-hub with power supply but no luck…

The LED is steady green and according to the software and the scanner is connected and working.

I have of course tried to find clues in other threads about the same issue but none of the workarounds seem to help.

Hi @Mattskarlstrom

That is interesting , I never had that issue via WiFi as that is a specific USB issue .

Can you please connect your POP2 via WiFI to your phone’s mobile app ? To see if your hardware is working correctly?

Usually you get that message when the software can’t connect to the data from the Depth Cameras in time , in other words time out .

Did you check your Device Manager if both Camera are visible ?

Please write to customer@revopoint3d.com with a link to this thread including your system information for technical assistance .

@Revopoint-Jane ( assistance)


Yupp, tried it with iphone and got the same message. Both cameras are visible in device manager to start with but after a few seconds they dissapear. The light on the scanner is still solid green though…

Seems to me that it is a scanner-related problem, hardware or firmware but I am a dentist and not very tech-savvy so…


Hi Matts

Yes definitely sounds like hardware issue if both your phone , computer and both USB and WiFi gives you the same issue …

Please write to customer@revopoint3d.com as I asked you before .

I will tag in @Revopoint-Jane in for assistance in this case .

Don’t forget to include the link to your thread here in your email to the customer service … you will need probably an appointment the technician to check on the hardware issues .

I have exactly the same problem as Mattskarlstrom.i.e. "camera exception. Failed to… etc etc… both on computer and over WiFi

The only difference is I’m using an Android phone plus a Win 11 PC.

Usb and WiFi connection working fine. Phone app and Win app open and detect the scanner but when I select new project I get the camera exception.

I will contact customer support.

@denniswaugh please include all information , screenshots, video, whatever you have to show the issue to customer@revopoint3d.com for more clear and quicker support .

Next time please post your own customer service thread , as each thread is personal with own issue .

Thank you

I am having this exact same issue with the POP3.

When I first connected it to my computer, I was able to do one scan. I closed the Revo Scan 5.4.1 software, and it would not scan ever since.

I did the calibration process as required to first use the unit.

  1. Revo Scan 5.4.1 will show the camera as connected in the home screen and the camera will have a blue and green light on it.
  2. I click the “New Project” button
  3. The home screen will close and Revo Scan 5.4.1 will open to the project view.
  4. After a few seconds, the camera disconnects from the computer and the software shows an error message:

“Failed to get camera’s information, please restart the scanner manually.”
The lights on the camera are still blue and green while the message appears.

  1. I click the “OK” button on the message. At this point the camera’s LEDs will no longer be green and blue, but instead will turn red and start blinking.

NOTE: It is only AFTER I click the “OK” button on the message that the lights turn red and start to blink.

  1. I wait for about 60 seconds and the lights on the camera will stop blinking red, and light up its green light. Then a few seconds later the blue light will turn on. The software will recognize the camera again as if it has re-connected.

  2. I click the “Scan” button in the project.

  3. I get the “Camera Exception: Failed to get camera’s information, please restart the scanner manually”. The camera’s lights are still blue and green.

  4. I click “OK”. At this point the camera’s blue and green lights go out, and the right led turns red and continues to blink.

  5. Go To step 7 and repeat…

I have tried with with the following connections on my Desktop (My desktop has WIFI built in):

  • Computer USB 3.0 → (Provided USB 3.0 to USBC cable) → Camera’s USB-C port
  • Moved to a different USB 3.0 port on Motherboard → (Provided USB 3.0 to USBC cable) → Camera’s USB-C port
  • USB C Charger → (USB-C to USB-C cable) → Camera’s USB-C port (Using Wifi)
  • USB A charger → (Provided USB 3.0 to USBC cable) → Camera’s USB-C port (Using WiFi)

Here is a YouTube channel I posted about the issue.

This appears to be now 3 confirmed cases of people having this same issue. This is no longer a fluke, and appears to be a flaw / bug in the software or hardware that is rendering these devices useless.

Camera Firmware version v3.1.22.20230526.

NOTE: When the camera re-connects (Lights are green and blue) I can click on the settings icon and do a calibration successfully. However, whenever I try to scan with it I still get the “Camera Exception: Failed to get camera’s information, please restart the scanner manually”.

Here is an updated video showing the calibration works, but not the scan.

The calibration of the IMU don’t use cameras … total different kind of connection and data .

I did had the same issue for 2 months on my PC , after purchasing a 40GB speed new USBC cable with powered USB C hub , things resolved itself with the camera failures.

My motherboard did not provided enough power and data on a single cable and I have expensive PC .

To test it out , use the split mobile cable , and provide separate power supply with power bank , and USB C connected to your computer , if there is not camera failure, this means your USB port do not supply proper the needed speed when powered via single cable .

If that was a software issue you will have 20K of users not able to scan using computer … so 20K vs 3 cases is not indicator of bad software .

It actually works perfect on a single cable on my Dell tablet PC win11 … but not on my powerful workstation … so little strange

I believe the provided USB cables do not works proper on all systems for some reason . I have lots of them since I have all Revipoint scanners … updating to a proper well made cable made a huge change for me .

But before that please test out the split mobile cable to be sure .

The three we know of (now 4 including yourself as you mentioned) are only the ones that took time to find this forum and post the issue. This means the 4 people describing this issue is only a subset of a larger portion of people who simply returned the unit, instead of seeking out help. I have to assume that this number is much greater than the 4 people identified on here. There are most likely more that have not posted here. But 4 with the same issue is showing a pattern.

Also, it is not related to the cable. I used the WiFi connection with the exact same results. The unit was powered off of a 60W usb-c charger.

In addition, I also tried a high end USB cable. I used a USB 3.2 Gen 2 cable which I have confirmed is capable of 3.2 Gbps bandwidth from testing and 100w throughput for a VR setup. Using this cable I also powered it off the Nvidia USB-C port on the back of an Nvidia RTX 2080, which is capable of producing 100W output and also the 3.2 Gbps bandwidth. I have actually done a lot of testing on USB cables myself in the past due to testing power consumption and bandwidth for a VR setup. I have an in-line USB-C current / voltage measuring with PD sensing. I can verify that the connection had well over the ability to produce the required 1A.

In addition, the WiFi connection produced the exact same results (I demonstrated this in the previous video), where no cable was involved. The unit was directly powered by a USB-C PD charger capable of 60W. I believe it is rated for up to 3A @ 5V. This does not appear to be related to the cable, nor a powering issue sad to say.

If you had the same issues via WiFi that I never experienced , you should check if your privacy settings are turned ON under your Windows system / Camera

If that is the case and permission is on, this means your hardware have issue and I recommend to write to customer@revopoint3d.com as there is nothing else you can try out .

The split mobile cable helps in most cases when both the data and power is split … but I am afraid your case is different because it should not happen while connected via WiFi so definitely hardware failure .
The technical team will help you out with .

I have been trying to resolve this issue for the past few days. Using the split cable is also something I tried. I tried connecting it to the provided battery source, and even my own external battery source. Both ended with the same results, where it kept giving the error repeatedly.

I have contacted customer support, and they seemed to be familiar with this issue. So they seem to have come across this issue before. They explained that there seems to be a few bad units that are causing this issue. They have assured me that if I were to return this unit and purchase a different one, that this would not occur again. So I have done so. I am returning this unit, and purchasing a new one. Hopefully this resolves the issue. I have sent them the logs that they requested to help troubleshoot the issue.

Trust me, I really need this product to work. I have several projects that are time sensitive. So I am trying everything I can to get it to work. I am really hoping this is just a fluke of a few bad units.

Otherwise if it is a software issue, this is almost good for Revopoint, because it means that it can be resolved with a software patch, and not need to do a recall on several units for hardware.

So the new unit is on its way, and I will update on if it resolves the issue.

Since I was able to do one scan with it operating fine I know the camera did work. Which also leads me to believe it is not a hardware issue (i.e. cable). I was able to successfully scan one time. Then I “believe” the camera did a firmware update, and that is when the camera stopped working. But I don’t remember if it did a firmware update or not.

So I really think this is a software / firmware related issue.

It is not software issue and it is related to just couple of devices from production .and definitely in your case , My POP-series working now just fine and issue not related to yours either.

If that was a software nobody will have working device as it would affect all devices .

You get your new unit soon and the problem for you will be in the past .

I don’t think here is anything to add to this , if I know that you already talked to the customer service I would not even engage .
As here is nothing else you can do about but replace your unit .

And if you do please change to INSPIRE or POP3 . You will have much better working experiences with the newer models .

It was a POP3. It was a brand new unit.

Have exact the same issue with my POP 2.
-when connected to pc via usb on any port
-when connected to pc via wifi and usb
-when connected to android phone via split cable and powerbank (fully charged)
-when connected to android phone via wifi
The same error sa on pc (windows 11) as on android phone.
The scanner worked fine, then the other day the image started to flicker, so i restarted it and later worked fine again. Now I get only the error message…


Hi @compadre

Please write to customer@revopoint3d.com with your hardware issues .

I did already and got a very quick response. Thanks.