Scanners lost connection after newest Revo Scan Software update

After upgrading from Revo Scan 5.3 to 5.4.3 both my Pop2 and my MINI will not connect to the program. Both were fully functional and were scanning just prior to the update.

Both of them turn on, show the green light that quickly turns to blue, and they do not connect. I have rolled the software back to 5.3, rolled it forward again, I’ve swapped between USB-C and USB, uninstalled the program and all its files entirely, reinstalled it, and turned off/on my laptop several times.

One person in a facebook group mentioned this happened to them, but uninstalling and reinstalling fixed the problem. I’ve not had the same success. Anyone else have this happen or know what might be causing it?

Make sure your camera permission for Revo Scan is turned ON under settings of your operating system .

Sometimes after installation of a new Revo Scan the permission is not automatic granted.

Also try using WiFi connection to check if it is permission or just USB issue , changing the USB port may helps restore the connection especially if you use only 1 USB cable .

I did not experienced this issue and I used v5.4.3 for almost one month with various Revopoint scanners .


Thank you for the reply! It says my camera permissions allow access but it was “last accessed” moments before I chose to upgrade the software to 5.4.3.
I’ve changed wires and USB ports. When I plug the scanner in, my computer makes the “device connected” noise but Revo Scan doesnt react to it or consider the scanner connected.

Did you tried using WiFi to ensure that is not the scanner ?

I will tag in @Revopoint-Jane to check on this issue with the tech team tonight when the office opens. And see what causes that in your case .

But my guess is USB do not connect the way it should with the application … the protoc is slightly different than regular USB device .
Not your fault, this happens sometimes on the system .

Also you can also try using the split mobile cable and power it separately and data only to your computer , it could help restore the USB connection .

1 Like

Thank you! I really appreciate it.
I have connected to the MINI’s wifi signal and it still does not show up as connected in Revo Scan. I’ve also tried the split cord to power to an outside source other than my computer, that also did not help connect it to Revo Scan. When I do plug it in with either the USB-A or USB-C, my computer registers the device. Its just Revo Scan that’s not registering. This is happening for both the Pop2 and the MINI, so I think when I initially downloaded the newest update something went wrong.

Ive uninstalled and reinstalled older versions of the software one at a time to see if any of the older versions would work either, none of them have.

I’ve also updated the MINI’s firmware and now instead of a dark blue light, its just red so that might have made it worse :sweat_smile:

Unfortunately you made it worse now , red means the scanner can’t reboot properly and is stuck and will not connect.

Now you will have to make appointment with the tech team to fix it .

Please write to customer@revopoint3d.com and add link to this thread with all your issues .

It becomes a serious issue now so please don’t attempt anything on your own until you hear from the tech team .

Make sure they know about the firmware update and the red light in place of green .

That’s all I can help you here with at this moment .

Hi @alhendrix96

Have you contacted our customer service? If so, would you mind telling me your email and I will have customer service contact you.