Scandistance - Too few datapoints

HI all,

Just hope if someone can help me tell what is going wrong. I got the Range on KS in large part because it promised free-hand scanning and a 300-800mm scan distance with a slick video of people scanning large objects freehand.

Unfortunately, no matter how hard I try the “Too few datapoints” covers my screen almost continuously through every scan. despite changing the scan range from 300-500, 300-1200, 500-1200 etc. it seems that if I am not within a very small window from the object, roughly 300-350mm I will see this error. Irrespective the colour band on the side. Tried a paint can, small chair and my son and cannot get anything even close to a decent scan.

I watched the Youtubes but, unless well hidden, it seems almost all scans are made stationary on a scan table, not ‘freehand’.

Sofar I can only say I am deeply disappointed, there are free phone apps with better results.



please check you exposure settings.try on auto. also read here

it would help a lot to understand your problems if you could share a video or some photos incl screenshots of revoscan during your unsuccessful scanning.

Hi Ivan,

I deleted all my tries to-date to save phone space. Reading the response you included in the earlier answer I have some remarks:

  • My exposure was on auto, started with pretty much everything that could be auto on auto
  • Even if the depthscanner preview is mostly grey I still get the too few datapoints message.
  • “Keep distance from 30cm to 120 cm” is nice advice but any distance over roughly max 500mm seems to give the “too few datapoints” error and while the ‘image count’ and memory bar keeps increasing the central screen freezes and from the result it is clear no data is actually collected.

Maybe I am also a looking in the wrong places but “Please watch some videos on Revopoint YouTube channel” is nice but I have not found one that e.g explains “set it on Auto and set the blue square in the middle of your scanned object” which is quite cryptic. Also while “The left side is not much important” it is apparently important to keep it “gray with slightly red”

Is there an extended manual somewhere with clear screenshots on what to look for while scanning? keeping an eye on the ‘colour bar’, ‘depth preview’ and central screen with flashing warnings all at the same time is quite tricky. Maybe I am just a bit slow.

Not sure how to make a video and take screenshots while I am also trying to scan. I will give it another few goes with the paintcan and see if I can manage some screenshots.


1 Like

Hi Jeroen ,

if you want to scan bigger objects like your son or a char you need to change the scanning modes regarding to the objects size , the largest you find under Standard mode / Large Object , this will give you the largest distance while scanning and you don’t have to change the range settings , it is to hide the background or foreground , not for changing the scanning mode or scanning distance .

as with any new tool , you need to learn a little bit about its functionality and technical side of it , no matter you use mobile app or computer a learning curve is always there . And please don’t get me wrong , each time I am getting a new device to test I need to learn a bit and get used to it over and over again .

So if you want to scan largest objects , please change the mode under scanning settings , the range will show you the min and max distance according to the settings of the mode .
after that you still can slider up the range if needed to 1000 . Even if the mode is set to 800 automatic .
\As with all structured light scanners, you need to scan objects that have features , not less than 8 cm apart and 3 constantly visible in the FOV … Round objects like spraying cans or mugs, requires a marker mode since objects like that do not have any features or are symmetrical .

Please try again and take your time , if you need anything you can always ask .;



I had another few goes at the paintcan. Unfortunately it seems that I cannot take screenshots while the app is open. I did take some in-app screenshots which aren’t great but show some issues.
App settings
Accuracy - standard
Tracking: Feature
Object type - General
Texture - color
in capture
Hide Surfaces on
Range 300-1200
Depth camera; first try manual shows ‘grey’ so I believe that is auto, 2nd time manually at 5 which previewed the can clearly in grey with a bit of red
RGB on auto

The first try I needed to be quite close and and stay quite close. I moved the scanner around and up and down a bit. The result was something that looked like the International space station, an elongated cylinder with some smaller cylinders sticking out at 90 degrees.

The second scan, with the manual depth camera, I kept as level as possible at around 400mm away. Less datapoint error messages but still a few. The scan/image showed like the can was mirrored and this time it did not even want to process. I downloaded the share zipfile but cannot attach it.

I don’t expect first tries to be perfect but I have used a number of apps and tools over the years and this is the first time I cannot even get a simple cylinder shape to come even close to looking like one. I am probably missing something simple but I cannot figure out what.


ps. apparently I can only embed 1 image

1 Like

hi! this looks like some cylindrical object, am I right? can you share a photo of the object you want to scan? regular geometrical shapes like cylinder, spheres you cannot scan without placing some trackable shapes on top of it (e. g. markers and use marker mode then), scanner need something it can track and stitch frames together.

Thank you,

when trying to scan my son it was on ‘body’ and the distance slider showed 300-1000 but I definitely could not go as far as 1000 before getting the datapoint error.

I can understand a learning curve and maybe I am a little impatient but the manual in the app is pretty basic and the video’s with ‘Ash’ have a lot of joking around but I haven’t heard much about all the stuff you seem to be referring to.



Hi Ivan,

Yes, it is cylindrical, below a screenshot from a scan using Kiri Engine, 42 images and below minimum suggested but clearly and recognizably a paint can.

As mentioned I also tried a chairs, a small child one roughly 300x300x600 total volume but no luck either.



You cant go beyond 1000 and nothing wrong with that , this is the maximum range the scanner is working . I go with Range to 3000 distance with my internal software for testing … so telling me you have zero data at 1000 is something wrong here … and the only issue I can see with it is your Deoth camera exposure is too low. Set is on Auto , stand 99 cm exactly from a wall an take screen shot of the app , you should have data captured without issues.

Well that why I am a moderator … :wink:
There are more people on YT sharing their knowledge … you can check also my channel :

The workflow for all scanners is simple , keep the proper distance and do not over scan your models , always move leaving 20% of the preview surface for overlapping.

And yes many users use turntables because that is the best way to archive best results in no time … I don’t think anybody need tutorial about how to keep a scanner at proper position from a object, it is obvious , you use turntable still you holding the scanner in your hand , and if you don’t have turntable you walking around the object with the same distance moving down 60% each time you finish 360 degrees rotation …

I am doing my work for the last 25 years … so I know a little bit more , still each new tool need some time to learn and master … nobody knows everything , nobody is perfect… just take your time and follow common sense , don’t think about Range as a camera , it is not , you not filming anything with , you capture distortions on the surface you are scanning thanks to Infrared projector that project invisible pattern on your object , the pattern need to be distorted to be register , for that reason your object needs features .

I can scan a fuel body in under 2 min in Body mode , please pay attention your human object do not move while scanning as that can results in corrupt data , scanned object need to be complete still .

1 Like

Range is not a photogrammetry scanner , it is light structured scanner , and there are rules regarding how to scan using real scanner … and you cant compare both as that are 2 different worlds .
Cylindrical objects do not have any features for that reason cant be scanned with structured light scanners without using markers or having additional object in the scanning scene for replace the needed features .

1 Like

Thanks again PUTV,

On the distance; I get the big orange ‘too few datapoints’ if I am further away and behind that message the central screen does not update. After the compilation I only had a few lines, no solid’.

I’ll need to check the wall another day, getting late here but will try it out.



1 Like


ok, this is something I can start working with, my impression was it was a combo photogrammetry with pointcloud. I’ll try and read-up on ‘structured light’ and watch your youtube too.





Its me again. I have seen your 120s full body scan video with the range but I have downgraded from my son to trying to scan a rectangular cardboard box. Alas, no luck. I am trying to scan freehand with the phone but I have the impression all successful scan videos use a fixed setup with turntable and laptop?

Anyway; The distance remains only in green at 30-40cm at different settings and the too few datapoints pops-up very quickly after going out of that very narrow range. Walking around the box it also looses tracking very often, no matter how slow/smooth I try, quite different from the snazzy video in KS REVOPOINT’s new affordable handheld scanner lets you easily turn large objects into accurate 3D models - Yanko Design

Is there a real beginner video somewhere simply freehand scanning a very simple object or is there a very clear guide somewhere you can point me to on what the windows mean, what the best settings are to use etc. The guide that is on the website doesn’t touch on any of that and I am clearly too dumb to work it out on my own. Sorry, its very frustrating, this is the first time something like this has me completely stumped.

Hi @Jeroen68 you are using a box ? Simple objects are not ment to be scanned , that is not what a scanner is for , it needs objects with features .

This really don’t matters if the object moving around on a turntable or if you moving around the object , same thing , the difference is that nobody scans a box with it .

Find yourself a proper object to learn on and no the distance don’t have to be exactly 30-40 cm , change the mode to Body mode or Large object if you watch to scan things much easier .

Even a 2 pillows bundled together will be better than a box .
Try to scan some sofa or chair , add some elements to it for tracking , it will make things much easier .

Lazy Susan would be also helpful for you in place to running around stuff .
Lazy Susan or turntable will just provide steady scanning situation with proper distance at the same time .
So you can focus better on what you doing . Walking around with a shaking scanner will not do good .


Thank you for your patience. I used the box only after having no luck with more complex forms. Useless as it is it was just to try and get at least 1 working scan. The box was only roughly 600x300x400 so lots of angles in view but no luck.

Anyway, I went back to a chair as you suggested, standard IKEA children chair, placed it on a table for easy access, cleared space so I could walk around it. lots of angles and openings. Using the Android app and a Samsung phone with settings:
Accuracy - standard
tracking - feature
object - general
texture: color
range - auto (300-1000)
RGB camera - auto
depth camera - tried auto and manual both

I think you can guess where this is going; after a number of tries, not even close to a successful scan. While taking care to carefully move as straight and vertical as possible at a constant distance the ‘not enough points’ error popped-up numerous times as well as the ‘tracking lost’ error. One time, with the top half of the back squarely and clearly in all frames the ‘not enough datapoints’ appeared to moment I pressed the start button. Unsurprisingly after postprocessing I see an ‘explosion’, not a chair.

I made a first successful scan of my eldest in 2012 and printed her on my self-assembled 3D printer. I am no wiz but am no complete full and generally get stuff to work. Both errors ‘freeze’ the capture process and even in the preview screen it is clear that there is no re-alignment. It seems that the scan has to be errorless but how to do that if a few cm deviation from the ‘green’ 300-400mm gives an error and the system cannot keep track of the shape?

I keep trying the handheld option with phone because that is the main reason for buying this, I hoped it would help me make scans of damage to structures and equipment I investigate for my work. If the video shows successful scans of near featureless car hoods and couches, how can I keep loosing tracking and having insufficient points with as diverse a set of objects as a person, chairs, stack of different sized, angled boxes, a simple box etc.? Are you sure this cannot be a hardware issue? One other thing I noted is that while steadily moving the camera down the centre pane seemed to ‘zoom in’, showing a smaller area than before, and subsequently loosing tracking).



After writing the above I thought I should also try your 2 pillow suggestion, just to try out everything. 2 sizes of pillow, one off-white and 1 red, probably the worst trial, the screen was continuously flipping between too few points and tracking lost.

Lastly gave a backpack a go, dark blue, lots of pockets etc. sticking out. The first ‘bottom to top’ motion seemed fine and even processed later but the moment I shifted slightly right after reaching the top tracking was first lost and the screen subsequently froze on ‘too few datapoints’.

Maybe if someone at revopoint can do an intro video with an everyday household thing, showing exactly which settings they use and filming both the person scanning and what the screen sees it would help people like me figure out what might be going wrong. Otherwise the charger and tripod may still come in handy (but a bit expensive if they are the only working parts) because it looks to me like the actual scanner, or the software, are a far cry from what the video promised.

Jeroen , I scanned so many I heard with Range from 15cm to 2 m without issues, on turntable or not .

You was on a right path , then you choice a standard object , I told you to choice body or Large object to have a proper distance if your object don’t have enough features , by choosing bigger object settings it will give you huge FOV where less features are requested .

I am starting to believe that your phone is just not good enough to collect all the data , I have not idea what you doing but it could not be that difficult , so something is off .

I throw 2 pillows on a sofa and Range keep tracking it without issue no matter what movement I am doing , however I have set object mode on Body , so please try that .
Let me know also the amount of RAM your phone have just to make sure .
You can also make appointment with if you believe your device is not working as expected , they can check it out for you to be sure it is not just you doing things wrong what I doubt , this is not that hard .

Get yourself a lazy Susan if you are on a budged and don’t want to spent money on turntable but first make appointment to be sure your device is working proper .

And please try the Body mode or Large object under Standard settings
And stay away from boxes , that is not an object to be scanned using Light structured scanner … Light structured scanner needs complex objects with lots of features to keep tracking how more how better .


I am using a Samsung SE21 FE with 8GB RAM, no top of the line model but pretty decent, if that doesn’t work a lot of people would have issues I would think.

As noted I have now tried a number of different objects 4-7 tries per object starting with everything on auto. The pillows you mentioned did not track at all, several times.

I will find some time and install on the laptop and use the laptop for scanning but that is not at all why I was interested in the machine and also why I don’t want the lazy Susan. The reason I got it is precisely for freehand scans at a jobsite, not a perfectly set-up studio environment.

Anyway, I’ll try the laptop to see if it makes any difference or if it might be something to do with the hardware.




Don’t have time for a long trial today but just now installed the pc software and connected the Range to scan our couch, covered in pillows and backpacks (not just to test, always like that). I got 1 or 2 not enough points and a tracking lost but something very closely resembling the couch in the 3D preview after stopping.

I than tried the same with the phone. After having checked the memory earlier I also stopped all programs using RAM but same issues as before, immediately had multiple errors.

So it seems that it may not be a hardware issue but that it simply does not work on the phone, at least not one that isn’t high end.

I’ll need more time to have a few practice runs and walking around with laptop and range isn’t particularly practical but I’ll try. Will also see about using over WiFi but it will be tough to keep an eye on the screen in that case while walking around.

Hi Jeroen , it seems like hardware issue , I will move your thread to customer service.
@Revopoint-Agnes should check on your issue tonight .