Samsung Galaxy S20 FE and Revo Scan

I have this weird problem that I only experienced with the Revo Scan app.

At first, I thought it was crashing but then, if I go in settings or any other feature in the app (New Project) it always goes back to the previous menu making scanning impossible.

Obviously, once it’s at the main window and “it presses back”, the app closes.

Any idea on how to fix this extremely aggravating bug?

What Revo Scan Android version you use ?
Did you download the last version ?

I’m using the latest one in the Play Store.

I tried to recreate this issue but for me it all works fine on multiple Android devices . I did not noticed anybody else having that issue yet .

It is hard to put a finger on what is going on with your system .
You have enough space and enough RAM on this phone to work proper . The original phone system runs Android 10 so hopefully you got an update to a newer version by now.
I tested with Android 12 on my multiple devices .
I will tag @Revopoint-Agnes to this thread, maybe she have more clue about what is going on .

Hmmm I might be too up to date…

Also, how much RAM is required to run the app?

I hiver between 1.6-2.2GB of free RAM.

The latest version of RS is 5.0.3 for Android
The requirements for minimum of RAM is 4GB , so typically the best phones with 4GB of RAM and up are preferable.

However don’t worry , since the new Revo Scan saving the whole project to your
phone Hard Drive , so you have more RAM to disposition , or you can import the RAW project scan to computer and finish it .

You will be able to scan with 2GB of RAM that you have left when running your system , I assume your phone have 4GB of RAM ? What is the minimum requirement for good performance.

I tested on my 6GB phone , I had like 4GB left for disposition and not even half was used while scanning . Before it was a different story.

The S20 FE 128GB has 6GB of RAM.

I deleted a bunch of apps and got it to 2.9GB of free RAM but after about 11 seconds, the app just shuts down.

For the minimum requirements for an app, I think it’s important to consider that developers take into account system apps plus theirs when they spec their software so I don’t think you need 4GB of free RAM, I think your phone has to have 4GB of RAM on the hardware side.

I have an old S10 that I factory reset recently, I’ll set it up and see if it has the same problem.

Same thing happens with the S10 that has 3.7GB of available memory. It crashes after 10 seconds.

I mean a phone with total of 4GB of RAM, . The app using now much less RAM than before .

What you used for connection ? USB or WiFi ?

It is very odd that the app crashing , none of that happened on any of my android devices , I wonder what trigger it .

If you use USB cable , it may be trigged by the OTG and it get back to the main window , but when you connect via WiFi it should stay connected without issue .

I get this. It does that when connected via USB. I guess I’ll try the WiFi mode.

Is it normal that it also does that when there is no scanner connected? For example, I’ll open the app without being connected and it’ll crash.

The message is random , however it is very weird that it crashing on itself.

Something is not right with this , hopefully we get some answers on that on Monday .

Thanks for the feedback.

And yes, the msg is just a generic msg you’ll get when an app keeps crashing. I just wanted to show it.

1 Like

Knock on wood but I think I may have fixed it.

I didn’t reset my phone but I reset all settings on the phone which will take me some time to fix in itself but the app stayed open for more than 30 seconds without shutting down.

It gives me hope, I’m trying with the scanner as soon as I get home.

1 Like

That’s interesting , thanks for letting me know … can’t wait to see if it works while scanning …