Android V5.0.6 on Galaxy S21 FE camera not working for sharing


I have a Samsung Galaxy S21 FE with stock Samsung Android 13 and One UI 5.1.

If I want to scan the qrcode in project share mode I got an indicator in phone that a program accessing the camera (green tiny dot). The red scanning indicator line goes from top to down with noticeable big jumps (not as smooth as I remember with S10) and the display is black (except from the texts and buttons).
When I turn the Camera off Revoscan / the OS detects it and ask me if I want to enable it or not. After I enable it I got the same result as above.
Other camera software are working great.

RevoScan is v5.0.6 from Google Play.

Hi @sz-range , I run on Android 12 , working fine for me here , maybe has to do with Android 13 … not much I can help you here with , but I moved your issue to customer service , maybe they have better idea about this issue , I will tag @Revopoint-Agnes / @Revopoint3D-Gena one of them will check on you after they are back in office tonight after 9:00 PM ET

This is what I see during share qrcode scan…

Interestingli during screenshot for a subsecond I was able to see the picture of the camera and after it went back to black.

From that screenshot it looks like both devices are not on the same network , The support will check on your issue tonight since I only run Android 12 and cant confirm if that is a bug on Android 13 or not , did not saw anybody else complaining about since the last app release . Just make sure you have the last mobile app version and the last windows version …

The text is not relevant as I just created the screenshot to add some more details to the case. No computer was involved during the screenshot.

@sz-range Hi there, I didn’t get clear o the issue you mentioned, could you please share some videos to and tag this forum link, our customer service team will reply asap

Is there any chance your phone camera is occupied when you scan the QR code on the computer?

Hi, one question. Does it only fail when you use the QR code? Or also when you use the 4-digit code?

My only problem is that I can’t scan the qrcode with the camera. Putting the numbers in by hand works fine.

1 Like

Aha, I will do some testing in the afternoon/evening as I can get a s21, to see if it I can reproduce it

No. Only the RevoScan try to use the camera.

I sent a mail to with the requested video.


It worked fine for me. The only difference is that I used a slightly different s21 (not FE, a standard 5G version)

What I noticed was that on the s21 the app was a bit bumpy before being able to read the QR, but with my own phone (realme GT) it was way smoother.

Perhaps it is something related to that particular subversion of the phone…

I use Atharok / BarcodeScanner · GitLab for scanning qrcodes. So it is definitely doable with the phone.

Another thing I noticed is that for subseconds 5-10 sec. apart the camera picture is visible and vanishes.

1 Like

I found a workaround.

If I change the “Motion smoothness” (this refers to the display refresh rate;) in Settings to Standard. The qrcode scanning starts working.

High has a 120Hz refresh rate which cause the trouble.

Is it possible to fix this issue so I can use High refresh rate also @Revopoint3D-Gena ?


The new v5.0.7 version didn’t fix the issue. (It was also not in the changelog)

The is always ahead with the build so this don’t means this currently version will have fixed issues regarding to the type of phone you have , they have a long to do list and try to fix things as fast they can …
Hopefully in next version this issue will be resolved .