POP low FPS with Revoscan5

Hi. New to the whole scanner world, so this maybe an obvious fix, but its stressing me out. Bought 3 different laptops with same issue.

Using POP1 on Revoscan5 and its almost unusable. The FPS is usually sat at 2.5 , some times at 3.2. Best ive seen it as is 4.0, but inly briefly.

The refresh rate is so low its just unusable by hand scanning. I have the revopoint dual axis turn table, but even at its lowest speed, the scanner still can not keep up and ends up losing the tracking.

Current laptop im using is brand new ACER Vivobook Ryzen 5 8GB

I have it connected to my laptop via USB 3 cable, and also tried USB C with same result. I cant seem to get wifi to work, the laptop does not see it as an available network.

Original Revoscan works OKish, just doesnt seem to scan as good as 5 does when i do actually spend ages and scan somthing in.

Is it just my laptop is not good enough, or is there a setting I can change somewhere to help? The scanner is soon to end up through the window with the first 2 laptops at this rate.

Hi @Bigmac , POP1 don’t use regular WiFI, only via Hot Spot , you need to create Hot Spot on your phone or Computer using POP1 , please refer to the documentations or check the Tutorials section of the forum .

Regarding the slow frame rate , it should be not lower than 8 FPS , I cant help you here , I will move it to Customer Support for Technical issues with your device, they will help you out .

@Revopoint-Mia | @Revopoint-Jane

@Bigmac I’m a POP1 owner and I’ve had my best scans using the mobile 2-in-1 cable with direct USB connection to my phone/PC via the USB C lead and dedicated 2A power supply to the USB A lead.

I wouldn’t even bother with Wifi hotspot mode as I can’t get good enough throughput to the POP1. Focus on making sure you supply enough power to the POP1 separately while supplying a direct USB 3 data connection.

Thanks for the answers.
I just got connected with wifi, instantly 9.4 to 10 fps.
Will use this for now, then look at the split power as also mentioned.

Thank you !


I also use only the split cable , but I think it was not provided with POP , as I had to purchase it separately, the single USB cable never worked for me and will not work with a phone …

Anyway happy you got it working via WiFi hotspot

Hi everyone ! I’m also having a very slow frame rate issue when attempting to use my POP 1 with Revoscan 5.x software builds. I’m getting maybe 3fps at best which is unacceptable. The issue could be that my POP 1 has an old version of the firmware… I just checked and the current firmware version installed in my POP 1 is: v1.8.1.20210520 and the Algorithm Version is: v6.6.3.0207. I am currently connected to my computer via usb 3 and running Windows 10 Pro. I should also add that the performance/frame rate is improved when running the Handyscan V4.x software. I would like to try and solve this poor frame rate issue, perhaps I will need to update the firmware in order to do so. Can anyone from Revopoint advise as to how I should proceed? If anyone else has any comments or suggestions I’d welcome them. Kind Regards, Joe Saltzman

Hello Joe,

POP1 should be not slower than 8FPS and around 5 in marker mode .

I suggest you write to customer@revopoint3d.com and request an appointment to update your firmware , sadly it is impossible to do it by yourself via the software .

There is nothing else you can do regarding the firmware other than be helped by the technical support directly via Revopoint in real time .

The procedure don’t takes long and it is easy process .


Hi Catharina,

I understand completely. Thank you very much for this information, I will see what I can do to set up an appointment with Revopoint for a firmware update. Thanks again and have a wonderful day !

Best wishes,


1 Like

I am using POP1.

I am experiencing the same problem as Mr. Joe and cannot scan properly with RecoScan5.
I saw this article and sent an email to “customer@revopoint3d.com” but have not received a reply.
How can I get support for pop1?

firmware : V1.7.2.20210309

Hi @Mak

I sent you a chat, please check it out, thank you!


I’m having the same problem with my pop1.
Is there any fix available or do we need to do it trough revo helpdesk ?
Firmware is: v1.7.2.20210309

I allready tried customer service and my question was forwarded but still no answer (or maybe im too eager to get scanning again).

Thanks in advance!

Hi Rubin ,

You need to go through tech support as here is nothing in the forum that can help you in this case . You probably need a firmware update and that can’t be done without tech support .

They need to evaluate the situation and see the problem in real time .

I will tag @Revopoint-Jane to check on your support ticket as well , since you already contacted the support .


Awesome thanks!!!

1 Like