Pop 3 calibration - "data processing failed"

I tried to calibrate my Pop 3 today with the calibration tool in Revoscan 5.2.0 - the calibration itself is a little bit tricky, but with some exercise it goes well.
BUT: everytime after the calibration was done while sending the data to the pop 3 i got an error message: “data processing failed. Please recalibrate”.

what’s wrong?

I did not calibrated my POP3 as the test calibration was ok and my results are very good . It is not recommended to calibrate it unless you get issues .

This means the calibration was not successful and the score probably lower than before calibration, I would not calibrate POP3 with RS 5.2.0 , wait until the new version arrive, probably around 15th

I only calibrated because the accuracy test said always: Please run the thest again or recalibrate. The calibration board delivered with the package is a little warped and the marker sheet on it has wrinkles. Maybe this ist the reason that my POP3 yielded mediocre results.
As for now, i am not satisfied with Revopoint.

My board and all boards always come slightly warped , I put a heavy book over it on a floor is r table and left it for couple of days under .

My tests was ok so I did not recalibrate , if you can’t make proper calibration test , I would not recalibrate it , try to straight the board , also make sure you ambient light area is not too dark while doing it .

1 Like

This is how my calibration board looked like straight out of the box.
It is so massive that I can’t bend it with my hands, so also heavy weight won’t do this.

This is what I get from the accuracy check:
I ran the accuracy check several times and noted, that sometimes distance and pitch meter are rolling heavily even if I hardly move. Same during calibration.
Calibration process itself seems to be finished, but afterwards I get this message:

I am not amused.

Oh no ! Please write to customer@revopoint3d.com for replacement, you can’t fix it

The heat must be great to deform it so badly while shipping … please don’t use it for calibration , the results will be not good …

P.S I never got that bad deformed boards
It is time for Revopoint to change the base materials for the boards .

1 Like

Do you think it is only an issue of the board?

Definitely board issue in this case Daniel .
I am actually glad you was not able to calibrate and update your POP3 , as it would result in a disaster and not accurate scanning results .

1 Like

The supports answer was a cheek:
40x40 Resyl (Revopoint 3D)

Aug 6, 2023, 23:39 GMT+8

Hi Daniel,

Thank you for reaching out!

Sorry for the inconvenience .Please watch the videos to better understand the calibration:

Calibration Progress:

Tips: scanner should keep parallel to the table tops no matter what angle the calibration board is in(see attached)

What Is Calibration:

Hope this helps.

If you have any questions, please don’t hesitate to contact us.

Did you ask for replacement of the board and sent them the picture of it ?

I will tag in @Revopoint-Agnes to check on this issue with the board tonight when she is back in the office .

@Revopoint-Agnes , the board is damaged in shipping and needs replacement to function properly with the calibration software and nothing else , can you please arrange the replacement ASAP ?

1 Like

Yes I did. I even included my order number an adress
This was my mail:
Hi support,

with a more new Revoscan 5 you can check the accuracy of pop 3. Doing this, I got this message for several times:


So I tried to calibrate, but after the process itself, when sending the calibration data to the scanner, every time this error message shows:


This is how my calibration board looks srtraight out of the box:



As you see, it is warped and has a wrinkles top sheet.

Please help!

Do you think this is an issue of the calibration board or the scanner itself? The software says it was last calibrated on 2023-06-19.

Please also note that the accuracy of my pop 3 was not very goode even before trying to calibrate.

Until now, nobody from revopoint referred to me…2 working days. :frowning:

Hi Daniel ,sorry to heard about that , I will leave a note for the support team personally when the office opens tonight .

1 Like

@Archaeoscan.by Hi Daniel, could you kindly send me your email address? I will check your email asap and send you the replacement~

Hi Cathy, Hi @Revopont-Mia,
yesterday the new calibration board arrived - i tried to calibrate twice, the process was much faster than with the old one -
but “data procession failed” again.
I really need technical and customer support and help. In my opinion the Pop 3 is out of order and should be replaced by a new one. But it wasn’t me who damaged it or made strange things with it. No high, no low temperatures, it has always been at home, no crash from the table or anything else.

Hi Daniel , that is indeed very strange , I calibrated my POP3 3 days ago and everything went well in RS 5.2.3 .

I think you need to make appointment with the support team via zoom , or you can record screen video showing this failure while upgrading the Calibration data to your POP3 .

If you make the video , write to customer@revopoint3d.com ( not in the weekend as the office is closed until Monday) add @Revopoint-Mia as reference in the email .

They may do an appoint with you to check it out or restore the firmware via Internet and if that don’t works then they will replace it , but from my experiences it should fix that issue as I did that once before with my beta device .

@Archaeoscan.by Please don’t worry, we will help you solve the problem asap.

Note: Revopoint provides online one-to-one video assistance, welcome to book a meeting with us!

Hi there,
today was my zoom meeting with revopoint in Shanghai - a nice lady translated in chinese to a technician, felt quite amazing!
What shall I say - it must have been the demonstration effect that the calibration worked on the first try, even if I was a bit nervous and shaky;-) And this after I had tried on my own for at least 10 times!
Did they update the firmware stealthily before the appointment? :wink:
I can’t explain this…
The only differences to my unsucessful tries were that the ambient light was very bright today due to a sunny day and that I tightened the usb connector screw really firmly. Maybe the latter was the main reason for failing.
Big Thanks to Revopoint staff and @PopUpTheVolume and @Revopoint-Mia for giving excellent support!


You welcome @Archaeoscan.by

The bright ambient light may be the answer…

Glad you made it finally … and no , the firmware was not updated :joy: