Mini stuck with red light after firmware update


I haven’t used my mini in a bit and set it up last night to notice an update for Revo Scan as well as a firmware update.

After allowing the firmware update to complete and restart the update Revo Scan and plugging my scanner back in, the scanner will not connect anymore and the light stays red.

I’ve tried this via Wifi as well and there is no difference. I’ve read through the many topics about resetting and tried that. After completing the firmware update again, it remains unconnected with the red light on.

Could you please help? Any info. would be much appreciated.

Thank you,

Greg Krywusha

Hello Greg

Sorry for the delay , if you have any issues with your hardware please always write to
They will handle your hardware issues as that is all I can do for you here , since you tried to reset it already without success , there is nothing I can do to help you here in the forum .

I hope your problem got resolved in main time … if not please contact