[Solved ] MINI Blue light fault

Hi All,

Seen a few posts similar to this but not sure what else I can try.

Got my Mini a couple of weeks ago, brand new and I’ve only scanned a few times and now it appears to be faulty. When it connects to the app there is a quick flicker of blue light and it never comes back on again. The RGB camera is working and the camera connects to the app via usb and/or WiFi but it can’t scan as it can’t detect any points.

Pretty gutted as I’ve wanted a mini for ages and still have my POP2 which has never given me any trouble.

Powered by the 3.0 USB from my PC, revopoint power bank, IQ power bank and externally powered USB hub and all give the same results.

Attached a picture of the device powered up with the green light on the back and as the picture shows, nothing happening at the front.

The device is getting warm but I’d expect it to get warm when powered.

Any advise on how to get this working again?

1 Like

Nothing you can do about … if the RGB is working but not the Blue laser we got a problem here.

I will tag @Revopoint3D-Gena / @Revopoint-Agnes to check on this hardware issue .

Please do not attempt any other tricks or tips … until you hear from Agnes or Gena

I am moving your thread to Customer Support for future assistance.


Hi DRR117, please don’t worry, we are here for you.

  1. Please connect the scanner to your laptop via a USB cable, put a piece of white paper near the scanner, and observe if there is a white line showing in the depth camera.
  2. Send the video and your order number to our email customer@revopoint3d.com, we will check and reply very soon.
1 Like

Good day! I have the same problem. what should I do. the white sheet is slightly visible

Hi @bigben

Please follow this and sent the results to customer@revopoint3d.com

  1. Please connect the scanner to your laptop via a USB cable, put a piece of white paper in front of the scanner at the exact distance of 15cm , and see if there is a white sheet showing in the depth camera.

  2. Send the video or screenshots showing it and your order number to our email customer@revopoint3d.com we will check and reply very soon.

Good morning. I wrote to customer@revopoint3d.com
I hope there will be some answer.
The topic is completely dead.

Hi @bigben

We can’t fix your hardware issues in the forum , this is hardware and warranty issue that need to be handled directly via Customer Services to determine if you need replacement.

Since this includes handling of personal information , you need to wait for reply from customer@revopoint3d.com

I am surprised you waited 3 months with your issue to be resolved .
And what do you mean by the topic is completely dead?

Hey boys and girls, found this thread and thought it would be a good idea to first post here before opening a ticket.
My MINI arrived a few days ago. Since then I try to start using it. So here’s the problem:

When powering up the scanner, the blue light turns on and does its job. After ~60 seconds, the light turns off and won’t turn on again until I cut off the power and restart the scanner. This happens in calibration and scanning mode.
I restarted my computer, did a complete and and clean reinstall of Revoscan, I launched Revoscan as admin, I even reinstalled the firmware (successfully) with the update mode.
I tried using the USB-A cable, the USB-A + USB-C cable, I tried using the handheld stabilizer and using the Revoscan app for Android.
Did my scanner really arrive broken? This would be pretty badass after more than three weeks of waiting… :frowning: :face_with_spiral_eyes:

Thanks in advance!

Hi @Socke4fame

Please write to customer@revopoint3d.com with your hardware issue .

We can’t test out your device from a forum or ask you for your personal information , so please contact customer@revopoint3d.com for further support .

Thank you

1 Like

In case anyone experiences similar problems as I did:
My scanner is DOA, nothing I can do about it. Luckily Revopoint will send me a new one.

I uploaded a video on youtube to be able to make clear when the blue light fails.
And please don’t laugh too hard… I didn’t know the tripod is telescopic :rofl: