Constant disconnect error code 7 black lower window

I purchased it new in box from someone who got it a few months ago and never opened it. I am having troubles getting a reliable connection to the 2 phones and the 2 different laptops I have tried. I finally got it to connect via wifi, it has a green light on the back, and the handyscan software detects the device on all 4 devices (2 different windows 10 laptops, 2 different android phones). The trouble is it only stays connect for a very short time before I get the following warning from Windows:
Get frame data error error code 7 please wait.
Yes, I have made sure my camera is shareable in windows 10, I have tried it powered from the laptop itself, as well as 3 different USB power banks, all the same result (yes they are all rated over 4 amps). I’ve uninstalled and reinstalled drivers on windows, reinstalled the windows software(also tried V4 which I gues doesn’t support wifi yet since it never showed as connected) nothing seems to fix it.
On the android side of things it will connect, but loses connection at about the same time, maybe a minute after it shows connected (no error code provided).
When trying to connect with the cable directly to the computers it connects, and then reboots itself as well, which is why I went wireless, to avoid possible problems with power output from the laptop itself. Also the bottom window never fills in (just stays black) while it is connected (windows and Android), and I don’t know if that’s normal. I have emailed support, and sent a few pictures, just wondering if anyone has anything else I can try while I wait for a response!
Pop error

In Handy Scan, check the default Hotspot name in About / WiFi / Settings (the POP has to be connected via USB, of course) and verify that your computer’s Hotspot settings are the same. Also, verify that the computer is reporting one connection (this can be done with the POP powered up, even if Handy Scan is not running, but that is not necessary).


Yup, did that in V3, and connected it to my home wifi, it just never showed up in V4m so went back to V3. Again though, it’s connecting, just not staying connected after that message pops up, it reboots itself, then connects again before repeating the process. Si I literally get about 30 seconds or so to see anything, or change settings. Since it’s also not staying connected when plugged into the 4 different devices I suspect the issue isn’t the type of connection but something with the unit itself

Plug it in and let it run for a few minutes, then check the temperature of the case. If it is more than comfortably warm, then it probably has a hardware error.


I didn’t mention it before, but it gets VERY warm while plugged in, warm enough I won’t put it back in the Styrofoam for 15 minutes after unplugging for fear of melting

You seem to have cause for warranty replacement. @Revopoint-Cassie is out on Chinese New Year holiday, so you’ll have to wait a few days to advance on this (I think they’re getting back on the 8th), but she will probably be your contact for this to happen.

Thank you for the help! Anything else i can troubleshoot?

Nothing comes to mind. Your unit appears to have a hardware problem, but Revopoint support will be better able to help you when they return in a few days.

Still haven’t heard from anyone with support

@Revopoint-Cassie , what do you think of this?

Hi @Sparkinman

Sorry for my late reply.

Could you please send us a video which can show the problem you mentioned? You can send it to our, and CC, thank you in advance for your cooperation.

If our product team confirmed it is a hardware issue, we will arrange a replacement for you.

@JeffLindstrom Thank you for your reminding. I missed this post before.

Best Regards

Does this help, its been open with tech support with little response?

Have also forwarded previous emails, photos, and videos to above addresses. Please help!

Hi @Sparkinman ,

Sorry so much for the delay. My colleague in the Customer support team is also very busy after backing from the CNY holiday.

I have told the team to reply to you as soon as possible. After they confirm it is defective with the product team, we will send you a new one.

Best Regards

@Revopoint-Cassie , tech support confirmed they were going to send a replacement fir the defective unit, its been 2 weeks since, i have reached out 3 times in the last 2 weeks, and no response, no tracking number, not even an explination… is this normal for tech support? Its been 5 weeks start to finish on this, and ive made no headway.

Hi @Sparkinman ,

I’m sorry, I just see this comment. I push my colleague to reply you as soon as possible.

Best Regards

@Revopoint-Cassie I had a response last friday apologizing for the 2 week gap in responses, and an email saying a replacement would be sent Monday. 2 followup emails, and 5 days later, still no response…what gives with revopoint customer service?

From what I have read, Revopoint is “all hands on deck” to get thousands of POP 2 scanners shipped. I know that the personnel I usually interact with have been very busy, even though they do not work in shipping.