I just installed the newest version of Revoscan. Everything connects fine but when I go to Point Cloud Fusion it errors out every time.

Basically says Point Cloud Fusing Failed.


I moved your thread to customer service for technical support since I never saw this kind of error before , so hard to help you here out without actually replicate the issue .

You may post additional screenshots showing this issue for better assistance in this issue , also pls add your computer specifications like RAM etc…

@Revopoint-Mia or @Revopoint-Jane will check on you tomorrow evening after 9PM EST

@Titon Please don’t worry, we will help you solve the problem asap.

Note: Revopoint provides online one-to-one video assistance, welcome to book a meeting with us!

Not worried just weird. Once I start my scan no matter what how I set it up everything shows red when scanning. Is this normal with this update? I get the same error every time. Unable to fuse point cloud.

I will attempt to take a snap shot of what it’s doing

Hi @Titon

Please book am appointment for meeting with the support to solve your issue , it seems like it is hardware issue and can’t be fixed in the forum , you need to have hardware support team to check it out live to determine if you need replacement or not .
Simple images don’t justice this issue .

I never experienced that problem so no, it is not normal

This can indicate hardware failure to recognize the proper distance , or one of the sensor is not working proper resulting in corrupted raw point frame cells that can’t be fused

For that reason please book the appointment, usually it is via zoom where you can share your screen and the issue in live action .

When I get a minute I will setup an appointment. Safe to say I’ve had nothing but issues with this thing since I purchased it. I’ve already had to replace the unit once.

Sorry to heard that , I never experienced this kind of issues yet and I tested lots of scanners , that why I have no solution here for you .
It may be the hardware or the firmware so the will determine it while testing … hopefully it get resolved soon …
They can upgrade the firmware live on the meeting .

Hopefully you will not need to replace it this time , but from your experience it sounds like depth sensors don’t capture the data correctly… hopefully quick firmware upgrade will fix it . Unless there is something else going on .

Please let me know what it was after the meeting , as I am curious myself what caused that …

+1, After the update, a simple part on the scan was always red, a flat bumper cover, I made it matte, the scanner doesn’t pick it up, I added markers, it barely scanned


Hi @Alex666 , sounds like lack of features in your case , you can check your scanner by simply scanning the included bust on turntable .

If you can’t pls write to to make appointment with the technical support .

I have not done it yet but this update might be the issue. Scanner was working then updated the software now nothing. I am going to uninstall this update and try the last stable version

That is really weird , because nothing like that happens to all devices I own and they working just perfect .

I suspect the installation may be corrupted so try to reinstall it and see if it works , if not roll back to early versions that worked to see if something else is going on .

It can be the USB driver, or firmware not responding proper to latest version ( I think it may be the case ) the team can reset and update the firmware while on the meeting to solve this issue if that is the case .

I uninstalled the recent update and reinstalled the last stable version. The scanner works perfectly with the older version of Revo Scan 5. I then attempted to reinstall the newest version and I get the same point cloud fusion error. Now if the scanner’s firmware needs to be updated to work with the newest RevoScan then that’s fine but in my eyes the newest version is flawed.

Hi @Titon
Sorry for the late reply.
Can you provide us with your computer specifications?
When the software is updated, the scanner firmware needs to be upgraded to adapt to the new version.
Is there a prompt to upgrade the firmware in the latest version?

Hello @Alex666,
Please write to and provide more information and they will help you with your problem.

After reinstalling the latest version of Revoscan it seems to be functioning again. After the install I accessed the settings for the scanner and it already states I am on the latest firmware.

Hi Don , it seems like the firmware kicked in and load the profile for the scanner correctly , I had issue yesterday with one of my MINI scanner that I did not used for 3 months ( my old Beta Mini ) … after couple of restarts it works fine again .
I did the dev team let know about that issues already .
Your firmware is the latest . I have the same … I believe they need to adjust the firmware and let us update it . I heard they planned it for the near future .