Revo Studio won't open

Strangest thing. I did a scan in multiple parts and they look great. Then I went to open Studio and to merge them but it won’t load. I click the icon and nothing happens. I reinstalled it, I restarted the computer. I tried clicking it directly in the Program Files folder. No dice. This is Windows 11.

Perhaps try running Revo Studio in Administrator mode.

Good idea. Sadly it didn’t work. The “run as admin” permission thing popped up and I said yes, then nothing. Thankfully I have another computer I can use Studio on.

I heard early from the team that there maybe missed some component on Windows11 that is needed for Revo Studio, but kill me …I forgot what it was

Oddly it worked fine until last night.

Then it is even more strange :astonished:
Sorry I wish I could help you

Good news. There was a huge windows update. It took hours to download and install but once it did Revo Studio worked again.


Would you please post the Windows 11 build info?

Easily done by tapping the Windows Start button and entering “winver” in the text window.

Winver says Version 22H2, build 22621.674