Revo Studio installation blocked at Visual C++

I am unable to complete the installation of Revo Studio The problem is that it repeatedly prompts me to Repair, Uninstall or Cancel the concurrent installation of Microsoft Visual C++ 2015-2022.

I selected Repair many times (upwards of 10), usually accepting the reboot prompt, but it never gets beyond this step. I tried selecting Uninstall, but that didn’t help (neither did Cancel). I then manually uninstalled both versions (yes, I had two) and rebooting, but that didn’t help, either (made it worse, actually, because it prevented IrfanView from working properly, so I had to re-install that).

I also tried installing in Administrator mode, but that didn’t survive the reboot.

I have turned off the Autostart setting, so I could try to continue installation in Administrator mode.
I could also try an independent installation of Visual C++, but all my experimentation takes time, so if there’s a quick solution, I’d like to hear it.

Thanks in advance.

I am actually stuck at the same point of the installation of Studio. Stuck on the installing prerequisite software.

UPDATE: After uninstalling did a new install and the installation just ignored the “prerequisite” for C++, installation completed and appears to be working fine.


Yeah, there is a problem with it. Had it yesterday, when installing either RevoStudio or RevoScan (Studio might be). But for me the VC++ installation said that the newer version is installed already and asked “Repair, Uninstall”, but when I clicked Cancel, the software installed and looks to be working (didn’t connect the scanner, so the RevoScan wasn’t tested).

But that installation have ruined my 3dsmax installation, so it no longer loads - looks like it breaks up all the Autodesk software. It began to say it can’t start the licensing system. Had to uninstall all those, clean the registry and reinstall them back, only then got them working back.

Seems Revopoint installation messes with system files (with VC++ installation or any other way), that can prevent other software from working. Revopoint, please, correct the installator, so it won’t break the software on the systems it is being installed on.

I just canceled it after first reboot when it ask again and that is , Revo Studio installed after and done , everything is working .
I had no issues with any other programs .

@Harh yes it is possible it messed up your original VC++ installation if you repaired it or uninstalled , if you canceled it, it could not mess anything .

They added the VC++ installation probably becouse people complain about not having the right components installed to run Studio or Scan … but not executed well and I did not had the chance to even test it before release.

1 Like

Dear All,

We notice this problem and will find the reason as soon as possible. Sorry for the inconvenience caused.

Best Regards

1 Like

And that’s why I’ve cancelled it, but even I press the Cancel button, I still had to reinstall software. So it did.


The VC++ installation should be not running when installing Revo Studio in first place , that is an old way, but becouse some other users complaining about not having the right component installed to run Revo Studio, they did this … everyone should install VC++ installation from Microsoft as I really don’t like it when software do that .

You should cancel it before installation then nothing will happen . Impossible to change anything in the system on its own as there is no way it can do that I run many other 3D programs that relay on VC++ installation and they working just fine and their licenses , if it ask for Repair this mean you have already installed it on your system . But from what you said you did installed it and it messed up your original VC++ installation . Not your fault here … it was bad bug anyway and never should happen in first place .

In first place Revopoint installer should be made properly to not to cause problems to the end users. Cassie stated up there, that they noticed the bug and will work on that, thank her.

As for me, I’ve already solved the problem, though it took me about hour and a half to do so. There shouldn’t be “you just should”, because the end users must have clear instructions, what to do in case they should do something specific. Not an afterwards note on the forum “you shouldn’t have stepped that bump to not to fall into the pit”. That’s not a blame to Revopoint, don’t miunderstand me.

I am glad your fixed everything on your system .
But you missed my point.
It really don’t matters …let’s just move on .

For those, who have tried to install RevoScan or Studio with no luck, you may just try to launch the installed versions. I’ve uploaded RevoScan and Revo Studio folders from my Program Files to the file sharing service if you wish to try those

This is an archive with the following folders. You can just put them into your Program Files directory instead of old ones you have installed. Just back the original folders just in case. When installing the first Revopoint software onto Win7 machine, I’ve just copied the folders from Win10 system, and those worked just fine, so it might work. Though it’s up to you. In case that file sharing service put password to the archive (it sometimes do so) , it will be 123.

1 Like

Interesting workaround (and it may work), but only if we can download the files and that ain’t happening.

I’ve clicked on the DOWNLOAD text and the arrow; all that happens is the screen flashes. I also clicked on the DropMeFiles text, but I was just prompted to select files for upload.

Very strange… I’ve clicked both “I uploaded files on DropMeFiles” and " DropMeFiles – free one-click file sharing service", and they both gave me the proper page opened in the new tab. Check if your browser supresses pop up windows. Anyway, here is that link as a text: dropmefiles .com/jgZcb - just copy and paste it to a new window and remove space before .com.

1 Like

Hi All,

We will release the new version asap. During this period, you can follow the suggestion from our mod. @PUTV

Best Regards

1 Like

Well, this was a puzzling path to success. I am a bit surprised that it happened, because I thought I was still a couple steps away from installing Revo Studio when it opened.

I manually uninstalled the Microsoft Visual C++ libraries (except the 2013 version, which is necessary for other apps I have on my system).

I then manually installed the 2015 library. This was a mistake because there is a larger one that includes 2015 through 2022. I am not posting the direct link to automatically download the executable because that is just not safe, so here is the page at Microsoft (so you can make an informed decision about what to put on your system): ; download the X64 version.

Having rebooted my system so many times in the past two days that I just wanted to avoid any additional aggravations, I right-clicked on the .EXE file and invoked Run as Administrator to overrun any hiccups.

I then rebooted, ran the Revo Studio .EXE file (also as administrator) and… hit the wall with another Visual C++ installation prompt.

Determined to power past it, I brought up Windows Task Manager, clicked on the Processes tab near the upper left of the window, then Name (which had the added advantage of separating the running apps from the background processes.

I selected the Visual C++ installation task and killed that, followed by the generic installation task (it’s labelled as being 32-bit).

And… Revo Studio opened on my screen.

Hi All,

You can download the updated Revo Studio without VC++ installation via this link:

And we will change the link on our official site asap.

Best Regards