Revo Studio Not running (Nvidia RTX2080)

Revo Studio Not running

My pc
AlienWare Aurora
Intel i9 9900K ( intel UHD graphic 630)
RAM 32GB
Windows10 Home 21H2 64bit 19044.1766
Windows Feature Experience Pack 120.2212.4180.0
Nvidia RTX2080
Nvidia Driver 512.59

Please Help
ex)
Another build For No GPU Assist version.
ex)
system have 2GPU (UHD graphic & RTX2080) please test. multi GPU env.

Does Revo Studio show up in the Performance Monitor list of Processes or Applications?

If yes, perhaps you need to assign it to run on a specific screen.

If not, try to run it in Administrator Mode to see if that helps.

1 Like

2022-06-21 18:03:21.519 [3356] [INFO ] [root] root logger is setup.
2022-06-21 18:03:21.519 [3356] [INFO ] [root] ####################################################
2022-06-21 18:03:21.519 [3356] [INFO ] [root] # START #
2022-06-21 18:03:21.519 [3356] [INFO ] [root] ####################################################
2022-06-21 18:03:21.520 [3356] [DEBUG] [root] setting user path == “C:/Users/not_2/AppData/Roaming/RevoStudio”
2022-06-21 18:03:21.520 [3356] [DEBUG] [root] app started,language type in setting “en-US”
“RevoStudio_en_US”
“C:/Program Files/Revo Studio/bin/shared/translations”
2022-06-21 18:03:21.520 [3356] [DEBUG] [root] fullLogPath “C:\Users\not_2\AppData\Roaming\ChiShine3D\revostudio\data\license.dat”
2022-06-21 18:03:21.520 [3356] [DEBUG] [root] fullLogPath “C:\Users\not_2\AppData\Roaming\RevoStudio\data\license.dat”
2022-06-21 18:03:22.058 [3356] [DEBUG] [root] setting user path == “C:/Users/not_2/AppData/Roaming/RevoStudio”
2022-06-21 18:03:22.058 [3356] [DEBUG] [root] setting user path == “C:/Users/not_2/AppData/Roaming/RevoStudio”
2022-06-21 18:03:22.059 [3356] [DEBUG] [root] QM File: “C:/Program Files/Revo Studio/bin/translations/revostudio_en.qm”
2022-06-21 18:03:22.071 [3356] [DEBUG] [root] setting user path == “C:/Users/not_2/AppData/Roaming/RevoStudio”
2022-06-21 18:03:22.071 [3356] [DEBUG] [root] QM File: “C:/Program Files/Revo Studio/bin/translations/revostudio_en.qm”
2022-06-21 18:03:22.076 [3356] [DEBUG] [root] Find license file: “C:\Users\not_2\AppData\Roaming\RevoStudio\data\license.dat”
2022-06-21 18:03:22.284 [3356] [DEBUG] [root] compare License And Hardware result: 0
2022-06-21 18:03:22.285 [3356] [DEBUG] [root] Plugin search paths: (“C:/Program Files/Revo Studio/bin/…/plugins/RevoStudio”)
2022-06-21 18:03:22.285 [3356] [DEBUG] [root] Required IID: “RevoPoint3D.RevoStudioPlugin”
2022-06-21 18:03:22.285 [3356] [DEBUG] [root]
Reading meta data of “C:/Program Files/Revo Studio/plugins/RevoStudio/core.dll”
2022-06-21 18:03:22.285 [3356] [DEBUG] [root] Current plugin IID: “RevoPoint3D.RevoStudioPlugin”
2022-06-21 18:03:22.285 [3356] [DEBUG] [root]
Reading meta data of “C:/Program Files/Revo Studio/plugins/RevoStudio/modelprocess.dll”
2022-06-21 18:03:22.286 [3356] [DEBUG] [root] Current plugin IID: “RevoPoint3D.RevoStudioPlugin”
2022-06-21 18:03:22.299 [3356] [DEBUG] [root] SOFT ASSERT: “settings.contains(key)” in file E:\Code\HandyStudio\ccqfc\csutils\theme\theme.cpp, line 278
2022-06-21 18:03:22.782 [3356] [DEBUG] [root] setting user path == “C:/Users/not_2/AppData/Roaming/RevoStudio”
2022-06-21 18:03:22.783 [3356] [DEBUG] [root] setting user path == “C:/Users/not_2/AppData/Roaming/RevoStudio”
2022-06-21 18:03:22.783 [3356] [WARN ] [root] QMetaObject::connectSlotsByName: No matching signal for on_closeBtn_clicked()
2022-06-21 18:03:22.784 [3356] [WARN ] [root] QMetaObject::connectSlotsByName: No matching signal for on_closeBtn_clicked()
2022-06-21 18:03:22.788 [3356] [DEBUG] [root] setting user path == “C:/Users/not_2/AppData/Roaming/RevoStudio”
2022-06-21 18:03:22.789 [3356] [DEBUG] [root] QM File: “C:/Program Files/Revo Studio/bin/translations/modelprocess_en.qm” true
2022-06-21 18:03:22.789 [3356] [DEBUG] [root] QM File: “C:/Program Files/Revo Studio/bin/translations/control_en.qm” true
2022-06-21 18:03:22.789 [3356] [DEBUG] [root] QM File: “C:/Program Files/Revo Studio/bin/translations/cswidgets3d_en.qm” true
2022-06-21 18:03:22.790 [3356] [DEBUG] [root] QM File: “C:/Program Files/Revo Studio/bin/translations/qt_en.qm” true
2022-06-21 18:03:22.796 [3356] [DEBUG] [root] setting user path == “C:/Users/not_2/AppData/Roaming/RevoStudio”
2022-06-21 18:03:22.914 [3356] [WARN ] [root] QObject::connect(QAbstractButton, Unknown): invalid nullptr parameter
2022-06-21 18:03:22.914 [3356] [WARN ] [root] QObject::connect(QAbstractButton, Unknown): invalid nullptr parameter

invalid nullptr parameter

This looks to me as though you have not properly registered Revo Studio.

Perhaps @Revopoint3d-Vivian, @Revopoint3d-Selina or one of the other Revopoint Support staff can help you.

2 Likes

@AmadeusRobot I saw many issues like that already and none of them was related to RTX card or graphic card driver . Revo Studios is s very simple software .

If you want to check if it is really the software issue , please install Cloud Compare - free software and run it , if it is also not working then I will tell you what to do next.

1 Like

I have the exact same problem. Double clicking on Revo Studio shows the rotating “hourglass” for a few seconds and that’s it! No visible start-up of the program and the Revo Studio icon does not show up on the windows-bar.
However, in task manager it shows up as a background process (adding an instance every time I start Revo Studio)

Both Revo Scan and Revo Calibration are working fine.

What i have tried so far:

  1. De-install and re-install Revo Studio. (used the latest version from Revopoint website)
  2. Checked for rules in Firewall. There were rules for Revo Scan and Revo Calibration, but NOT for Revo Studio. So I added a rule…but the issue still remains.
  3. Installed Cloud Compare as suggested by PUTV and it starts without problems.

I have an HP Omen laptop: AMD Ryzen 7 4800H with RTX2060.
However, the laptop also has an on-board Radeon graphics…could that be the culprit?

Any suggestion/ideas anyone?

In worst case scenario…is there an alternative for Revo Studio?

1 Like

Ok thanks , it seems like there is another issue on the hand with Revo Studio on your system .

Please use Cloud Compare as alternative until Revopoint support find out what is going on .

If Cloud Compare running on your system then there is no graphic card issue or driver issues, but something else .

Usually CC and Revo Studios do not works when there is driver issues .

@PopUpTheVolume Thank for your quick reply!!

As for now I will probably use CC…but first I have to find out how to properly scan objects in turn-table and free-hand mode and all the other aspects that come with 3D scanning. I’ve only just received the POP2 so I still have a lot to learn for the comming time!!

And that’s fine with me…I like exploring this new technology (for me anyways) and get into the nitty gritty details…!

But on the other hand, I would sincerely like to see Revo Studio work on my laptop.
And it’s not because “I paid a $#*!-load of money for this thing…and the software sucks big time!!”. But It’s because I believe it can work on any machine and I would like to find out the reason why it does not work on mine.

So, if anyone has some tips / tricks I’d be glad to try them out and see if we can solve this issue. Because I will probably not be the only one who will be having this issue…!

2 Likes

The most issue people had before like that was related to windows installation , but yours seems like something else .

I hope they find solution for you soon.

CC is much better, but hey, you want what you paid for and that is understandable.

2 Likes

Hi, would you please try to uninstall it and then download the latest version of Revo Studio? Make sure that the computer has enough room for it.

1 Like

Hello Selina,

Thanks for your reply!
I allready did the uninstall / re-install 3 or 4 times. And I always used the latest version from your website (Revo_Studio_for_win_v3.0.6.9.20220527).

  • It does not matter if I put it on C:\ or any other disk. There’s also plenty of room.
  • Installing it as Administrator does not change a thing.
  • Running as Administrator does not change a thing.
1 Like

Hi, we are working hard to find out the problem. I am sorry for the inconvenience. Any updates I will let you know ASAP.

2 Likes

@Henske01 @AmadeusRobot

Hello guys, as Selina mentioned above that we are so concerned about this problem since part of the users have reported it. And our R&D is investigating and analyzing it. Before we provide the solution, you can use other post-processing software instead of Reve Studio like Meshlab or Cloud Compare. As you know Revo Scan supports export PLY, OBJ, and STL format model files.

3 Likes

Hm…to keep going I installed the latest stable version of CloudCompare.
CC starts up fine, but after a period (between 1 ~ 10 minutes) it shuts down (without an error message).
It only shuts down right after I perform an action (segmenting, Translate/rotate, align, save, etc) but never when it is idle.

Tried starting it as administrator, and even deleted the plug-in folder (as mentioned in some post I read)

So, at this moment I have no way to handle multiple cloud files as both Revopoint Studio and CC are not working.,frustrating!

Is there an alternative which I could use?

Have you tried monitoring free/allocated memory using the Windows performance monitor in the leadup to this problem expressing itself?

There is something else going in your system , mostly with memory , and that has less to do with the software .

I saw many people had that issue and had to reinstall windows again to make things working as it should again .

I did not think I can give you other advice here since you already reinstalled fresh your graphic driver.

And I am afraid another 3D program will not work any better .

1 Like

solved.
The solution is to add a new account (admin User) to Windows and install Revo Studio.

3 Likes

You know I added early new account to my windows and Revo Scan crashed each time the new user directory was listed under the new account the moment I click New Scan , so I had to change the user path directory each time I switched the user accounts . But later it resolved itself somehow.

Hi, we have a beta version trying to solve this problem. Could you send me your email for receiving the version?

1 Like