POP2 meshed OBJ cannot be viewed in Windows 3D Viewer

tested on both Win10 and 11 machines, latest V4.0.0.0227a

When exporting a meshed model to OBJ I cannot open this in Microsoft 3D Viewer.
I can open the PLY version with the identical file size, but that doesn’t help me.

Just wanted to embed the object into my website but the plugin doesn’t recognize the OBJ

You can download the file from my website

You could try installing (the free) MeshLab. It will load Revo Scan’s and Revo Studio’s PLY files and you can export them to OBJ.

You can also verify if they open the scanner’s OBJ files, too.

Thanks Jeff, will try that!

To satisfy my curiosity, is it that RevoScan/Studio doesn’t adhere to standards when creating the .OBJ, or is it that .OBJ is indeed only a container format, and what developers do with that is up to them?

Here is when I try to import the bespoke .OBJ file into meshlab:


So there’s obviously something wrong with it ;-(

I’m beginning to think that somewhere along the lines this file has corrupted. I now have created another coloured scan, meshed it, textured it, exported OBJ PLY and JPG and I could open the OBJ in 3DViewer successfully, including colour texture. Will try from there :wink:

I am relieved to hear that because I just tested OBJ export on my system and had no problem. :blush:

The OBJ was not corrupted at all , it was not an OBJ it was a PLY file , rename the OBJ to PLY and you can open it everywhere . Sometimes it happening that when exporting the obj the software actually export ply files with the extension name of *obj , it happens to me not once already .

note : Revo Scan OBJ actually include the color vertex data in the files as ply would do if textures where not generated inside Revo Studio .

Yes I see! Could have happened as I am going to the learning process / developing a workflow…
I guess where I was struggling is: what file contains what to make colour/texture work. I then tried to re-edit / downrez the file so I don’t end up with such a massive file, as there’s a 128MB upload limit on my Wordpress library.
Finally managed to get one up on my server and display with viewer plugin, but unfortunately no skin…
here’s my testing page

any idea as to what I need to do to have the full model displayed?

The one that have textured you will find " mesh_text.obj in their names , there will be also MTL files and Textures , OBJ without MTL will not load textures in your plugin . You need to upload the 3 files OBJ, MTL and Textures.
If you prepare models for the web , you need to use lower scan accuracy or use higher cloud point fussing option like for example 0.3 in place of 0.1. , 0.1 will generate huge models , how higher the value how smaller the mesh in size but also less details .
Second option you have to remesh the scanned model and generate low poly model

1 Like

I am having difficulties establishing a workflow.
I did a high res scan.
Upon Stop, I choose to Not ‘Fuse the cloud point immediately’, hoping I could work with the initial data in Revo Studio. I cannot, because it will not load a *.csprj, but only ‘model files’
RevoScan: Choosing (…) ‘Open’ will open the project, but I get NO option to fuse the cloud, or create a mesh (even though neither has been created)
Choosing ‘Import File’ and select the very *.csprj says ‘project already exists’.
I then ‘delete’ the existing model and import the very same project which creates a new model.
But same here, I cannot fuse cloud points, mesh, or export.

How is that supposed to work?

OK, then I do a scan with cloud point fuse and export which then creates my pig8.obj which I can Import into RevoStudio.
I change parameters to suit, mesh the point cloud, and try to export the meshed model.
I then try to [Clip Export] the file which offers to overwrite ‘Mesh_from_pig8.obj’ which I [apply] but cannot find the resulting file (what does that do, exactly??).
Upon Exiting (???) the software I get asked if I want to export the file. Which I then save in a different folder, renamed, as .OBJ.
But there’s only one file, no _mesh , no _tex, and the model opens in Win3D Viewer without a skin.

Seems I cannot win.
I want to scan best resolution possible, then edit multiple version to suit different output. Want to be able to re-edit at a later stage.

1 Like

I don’t understand ‘Projects’, either.

If I were in your situation, I would export the scans in PLY format, then import them into MeshLab (it’s free, but complex).

From there, I could easily create several different versions by selectively reducing the polygon count and exporting them as OBJ files.

Sounds like a good idea, I shall check that out, thanks Jeff!

You see you already make a mistake , you can’t just fuse it and export as OBJ , it is not a valid format , fusing the cloud point do not create a mesh, it is still a cloud point.
You need to fuse it , mesh it and export it as OBJ to have a valid obj files .

Or Scan/fuse it/ export as *.ply and open in Revo Studio and Mesh it there , after that you can simply change the resolution of the OBJ to whathever size you want . It is not a rocket science, If you can’t follow a simple task here you gonna be lost in Meshlab .

OK it shouldn’t be rocket science, yes, but there’s no clear instructions anywhere, and on the other hand if my process wasn’t gonna produce a valid file then I also shouldn’t be able to export that way.
Happy to learn that .ply is the way yo go, shall try that next.

You don’t have to fuse to export as OBJ. It’s STL that does not support Point Clouds.

But, yes, the best workflow is to scan without fusing, then use Revo Studio to fuse and mesh.

Not all programs that use OBJ support cloud point in this format. Not need to confuse others Jeff , my quote is out of context, or everyone going to do that and tomorrow you gonna have a long thread saying they can’t open OBJ in windows viewer as it already happening too often . Because all they do is exporting cloud point as OBJ

Some people don’t knows what cloud point is or even OBJ. For Revo Studio it does not matter but for many other programs it does matter .

If he export cloud point as OBJ then he have obvious a problem with it , other way he would not ask for help .

sometimes it is better to do simple rule to avoid confusion , especially with a new software .

Very true, it is new software for me, and I am getting confused.
That said I live on the geekey side of the spectrum, and deal a lot with other softwares, stills videos virtual tours etc, so i am familiar with a steep learning curve.
But what I am struggling with is the distinct lack of in depth information readily available that would explain all that: concepts, models, file formats, process. I tried to find all that before writing this thread, but didn’t see much, either here, on the website or on the youtube channel, and fb. But I guess thats the attraction of living on the edge :wink:

Have you downloaded the manual or any of the tips?


You not going to find that at this moment , there are some process videos and small tutorials you can find by Revopoint’s youtube channel .

I assume since both software are still in beta there will be deeper Manual once the software becomes Final. Both POP and POP2 are relatively new to the market so there is not much about it on Internet yet beside some information shared by the end users.

Both manuals explains basic functions only at this moment since new functions and improvements are added on a regular basic.

BTW I am glad that Revopoint decided to expand the functionality of POP2 both the device and the software , so until everything is written in the stone I do not expect the extra informations yet.

1 Like