Now It Works on One Machine Finally!

I’ve tried it on two Windows 10 machines now. The software opens and immediately crashes. Edit - got it going.

Given that the software appears to run on everybody else’s Windows box perhaps the fault is at your end.

Some details would be useful if you want to find a solution.

1 Like

No problems on my end with windows 7 or 10 on 3 different desktop/laptops.

Run malwarebytes free and remove any junk. I would run ccleaner also and fix the registry but if you don’t know anything about fixing a corrupted registry where your computer will not boot then dont try it.

Make sure something is not using all of your memory (in task manager).

Just a few tips.

I’ve been using CCleaner for 15 years. Not the problem here. I’ve tried on four Win 7 machines and two Win 10. All with 16gb of RAM with most of it available.

The reviews at Amazon say otherwise. The software doesn’t run on everybody else’s Windows box here either.

image

This is a near failure in the software world.

1 Like

Hi @banjodave @KnightRid ,

Please kindly noted that the below software requirements, usually, we don’t recommend users to use the Win 7.

Best Regards
Cassie

Hi @banjodave ,

  1. Do you mean with POP or POP 2?
  2. Can we have an online meeting to check the problem directly? Then we can find the reason easier, for now, the information for us is too less.
  3. As for the Amazon review, not all users have the problem with you. (We met the users who use the iOS version and complaint that the App crashed, after they closed the other running apps, then the problem is solved. They are caused by different reasons, some are software bugs, but not all of them are caused by the software; some are because users’ firewall settings, camera settings, and the OS version are not allowed, and so on.)

Best Regards
Cassie

1 Like

I run the software for 4 months, scanned lots of objects and never experienced any crash for once , if it opens and immediately crashing that is your system issue , I saw so many users with this issue and at the end if was their messy system doing it . It can be anything from a left over from previews graphic driver to codes installed to run Kinetics
Second it will not works on Windows7 if it does then people are lucky as Win7 is not supported .
I run it on Win10, Android7 phone ,Android 11 phone , Android 7 Tablet, Win10 Tablet and nothing ever crashed .

The question here is, do you want help or you just come bashing something because it don’t works on your messy computers ? the Revo Staff has spoken , make appointment to fix it .

My systems are all clean and fast. I have been a CNC machinist, CAD designer, and CAM and robotics programmer for 30 years for a living. This is not a “my dirty systems issue” when so many others are having the same problem. Is it not odd to you that I run Solidworks, Autocad, Fusion360, FreeCAD, Mastercam, Mach3, Blender, Cura, Chitubox, and many others with no problems on multiple machines. I’ve done a lot of networking between Windows systems and Linux machines in Virtual Box. I was using hex at 12 years old in 1980.

I just did a fresh Win10 install (dual boot 10/7 on separate SSD’s) on my Precision 4700 with 16gb of RAM, twin SSD’s, and an Nvidia M2000M (shoehorned in from a Precision 7000 series with a custom .inf).

It finally works on my Precision now in Win10. It even works without being logged in as admin, which I saw people had problems doing.

I tried it yesterday on my wife’s Lenovo with Win 10 that’s even newer than this machine. She’s a civil engineer and uses that machine with a bunch of engineering programs. It wouldn’t run the Revo software. Open blank screen and crash.

End of story is that this software still has issues if it’s so hard to make it work on so many systems.

1 Like

So now you see after clean win10 installation it did worked as well , this means you may have something installed on your other system that conflicts with the software , the software is OpenGL 4 and web Based , it is very simple software .

BTW what are you trying to scan in your windows preview ? you will be never able to do that , first there is reflective metals that does not work with Infrared laser scanning and the wires are too small for this 3D scanned accuracy .

I don’t doubt in your credentials as professional , but you just started using POP2 hours ago and you not yet a pro with that, you are simply a newbie to it , and that is OK, we all where on some point
I am doing 3D works for 24 years and worked with many 3D scanners since the 90’s , but each of them needs a new learning curve . There is no magic button even if you spent $25K on a 3D scanner .

The last software update do not need to be run as administrator , and what people had issues with was an old software build , this is actually a new version and still improving daily .

So since it working on your clean version of win 10, this means your other system was messy as I thought , there was something that prevent the software from starting , usually left over stuff in the registry , as we all know Win10 is not ideal .

if you run in some issues while scanning just post new thread in the support forum and someone will be glad to give you a hand .

Got it going with fresh Win10 install. Thank you.

2 Likes

Hi @banjodave ,

If you can’t solve the problem, sincerely hope we can have an online meeting and let our developer team find a solution for you.

Please feel free to send me a private message if you need it. Thank you.

Best Regards
Cassie

I was not trying to scan anything. I was just making it sure it would open and the camera works. What you are seeing is internals of the CNC control I just built for the CNC router I just designed and built.

Now I will dual boot another pc for this where I actually plan to use it, upstairs instead of in my basement shop.

2 Likes