Has my MINI got bricked?

I received my MINI and dual axis turn table, connected the MINI to my Win11 Core I7 16GB Ram Laptop, and started Revo Scan 4.1.1. It showed a message pointing that I need to upgrade the firmware to be able to use the dual axis turn table, so I started the firmware upgrade, but it was not successful. So, I came to this forum looking for a solution, and as was trying the fixes I found here from plug and unplug and retry to pressing the button 10 times after 30 seconds from boot when I get a steady blue indicator.

The MINI was working as I preformed a test scan while manually moving the object and it was very good.

The problem:

After many attempts to upgrade the firmware, the indicator got stuck on blue and 10 presses won’t work anymore, and windows is not detecting the device in device manager.

A little Hope:

Interestingly, I tried something that wasn’t mentioned anywhere where I searched on the internet.

When I powered up my MINI I held the button while the indicator is white, and the indicator became red! Then I released the button while it’s red and it turned green for a while then blue and then it’s stuck at blue again.

I hope I can make it work and I appreciate any help I can get.

1 Like

If the led on the back is Blue after all the attempts, I guess only @Revopoint3D-Gena or @Revopoint3d-Selina can help you here , as you run out of all options available already .
I am not sure if they working this Saturday since they are on Beijing time ( right now 2:51 am Saturday )
If not they may be back at you on Monday with more support.

I have not had this problem, so I can only relate what I have read, but did you make the 10 button presses quick or long? I have read that it should be 10 quick presses.

Thank you all for the response.

thanks for confirming that, I sent an email to support and I’m waiting for their response.

I tried both and I’m sure that I did it the correct way as it worked with me twice before.

1 Like

I am also having the same issue as you, hope our scanner can get back to function… Waste of money if it failed then nothing can be done :pensive::cry::sob:

Support from Revopoint has been very good. If it’s truly broken they will replace it.


I’m waiting for support reply after this weekend. I hope they can give me a solution without sending it back. I’m emotionly attached to it already :smiling_face_with_tear:

1 Like

They will … don’t worry , once @Revopoint3d-Selina is back at work she will .

Have you received any reply from the email yet? May I know your email address? I can help to follow up on that for you.


This is my email mo-alqo@hotmail.com and yes I received a reply from Olivia.

Thank you for following up. :heart:

1 Like

My MINI got fixed after support, and here is how:

Thanks everyone :tada: