Cannot activate Revo Studio software (error 10)

I have tried multiple times to activate the Revo Studio software with the license code I was given and it has repeatedly failed to generate a key due to an “Error 10”. This error suggests that it cannot connect to the server to generate the code but my computer is online and I am accessing this forum at the same time I am attempting to generate the code so connection is not the issue…

How can I activate this software and start using it with my scans?

I’m not sure about “Error 10”, but you should make sure that the license code you are entering is just that, with no extra spaces or special characters.

I’d copy and paste into a pure text editor, make sure there are no characters at the end, then copy and paste that into the registration window in Revo Studio.

I have been copying and pasting it but I will double check and make sure. Thanks for the suggestion.

Nope. I double checked and there are no extra characters… even tried typing it out. Still throws the “error 10” and won’t let me use the software.

Sorry to hear that. I’ll tag @Revopoint-Cassie to look at this when she gets back from holiday (the 6th, I think).

Alternatively, you could request another CD License Key in this thread:

Add a note that the first key did not work; I’ve been told there is no problem getting a second key for the asking.

Thanks for the help. Hopefully another key will work.

I am not a fan of DRM software like this - once the server goes down, the software can’t be installed again. I have had this happen with other manufacturers (Pinnacle!). Please consider getting rid of this horrible DRM.


It has occurred to me that anti-virus or anti-malware software could be preventing the unfamiliar program (Revo Studio) from accessing the internet.

Try disabling it while you register your software.

well there is no specific key on any paperwork and the only key i have found was in the text file in the zip of the downloaded windows software, so i can not get it to work because it doesnt like the key

Hi @DrewScan ,

Please use this version and see if your problem is solved:

Best Regards

Hi @Robin ,

This is the beta version. We will re-consider this method in the near future.

Best Regards

1 Like