Revo Scan 5.3.2 on Mac

I just purchased a Range 2 with the hopes of being able to quickly scan my model and import it into my 3D design environment. Unfortunately I have run into a number of issues.

My first is that the Mac version (5.3.2) downloaded from the Mac App Store does not appear to support USB connections. I tried two mac mini M1’s running Sonoma 14.2 and 14.3 and the app does not detect the device once its plugged in. I even tried two different cables.

My second issue is that the WiFi connection is unstable at best with the device 5 feet from the Mac. When the WiFi connection is lost the only way to get the application to connect to the scanner is to reboot the mac.

Finally I am confused as to why all the videos on YouTube show a different GUI then what I am seeing on the mac. After downloading 5.4.2 on a spare Windows PC I noted the GUI is much different then the mac. Can someone confirm that they are seeing the full interface on a mac? All I see is the limited interface one would see on an iphone (shown below).

I never thought to look on the Mac App Store. But it says that’s the iPad version. Interesting that it runs at all.

You want this one for MacOS:

Hi @Plucker

As @TheBoatScans already stated you are using a mobile version of the software .

Mobile version of the software for iPad or iPhone don’t support USB connection .

You need the Mac full version to use Range via USB .